PDA

View Full Version : 1991 Superduty Ford with Wait to Start issues


trailbuilder
05-12-2011, 11:21 PM
I have a 91 Superduty, that is the 7.3 International engine....(GVW 14,500 that's why I like it). When I go to start it after about 3 seconds the wait to start light goes out and you can hear the relay or controller behind the firewall clicking very second. The glow plugs do not seem to heat up so I have to use starting fluid even in the spring/summer months. The Glow plug controller is $220!

Anyone have any ideas?

dbear
05-13-2011, 09:10 AM
Um, is this a trick question? I'd probably replace the glow plug controller, and consider replacing the glow plugs themselves. I used to have a hard-starting '90 F250 w/7.3 I did just that to it many years ago; thing started better than new. As I recall with mine, the plugs made more of a difference, but I don't recall having the clicking noise from the controller that you describe.

kodak mowing
05-13-2011, 11:17 PM
i have a 94 f250 7.3 idi turbo,it either 1 or more bad glow plugs or the glow plug solenoid on the glow plug controller,i replaced mine for bosch glowplugs $3 each on ebay and new soleniod $15 bucks,hope that helps

Milwaukee
05-14-2011, 11:38 PM
Time for new glow plugs.

By Way DON'T cheap on glow plugs. Would you put $1 oil in dragster engine?:nono:

Get motorcraft BERU glow plugs.

DQL10
05-15-2011, 12:43 AM
I believe the clicking noise is are the glow plugs still heating up. Atleast thats what they are on the newer diesels. Just replace the glow plug control module. Doesnt seem that expensive to me. Wait till you buy a newer one and have to replace the FICM! Thats when they get expensive.

Milwaukee
05-15-2011, 12:45 AM
I believe the clicking noise is are the glow plugs still heating up. Atleast thats what they are on the newer diesels. Just replace the glow plug control module. Doesnt seem that expensive to me. Wait till you buy a newer one and have to replace the FICM! Thats when they get expensive.


On my 6.9L IDI it doing that but it wouldn't stay ON. It come on for 2-3 sec but couldn't start. After replace whole glow plugs it come for 10-13 seconds then start like new.

wvmike
05-17-2011, 09:02 PM
its the glow plugs.

trailbuilder
05-17-2011, 11:17 PM
Thanks, I will try glow plugs first before ordering the controller.