PDA

View Full Version : Help!!! Burning Oil in Navigator


ha305
07-25-2011, 08:08 AM
We just changed the oil in our exmark navigator last week. It has a 20 hp kohler in it. It now is burning oil excessively. We did not change the filter, just the oil. I am at a loss here.

Please help....

ha305
07-25-2011, 09:03 AM
The temps were around if not over 100 in NJ last week. There were no leaks in the trailer that i can see also.

JDiepstra
07-25-2011, 09:23 AM
What weight oil?
Posted via Mobile Device

ha305
07-25-2011, 03:39 PM
Using 10- 30. Motor has 840 hours on it and it has been well maintained

ffemt1271
07-25-2011, 09:19 PM
head gaskets, just had the same thing happen to a 23 kohler, do a compression test to find out which side is bad

Mowingman
07-25-2011, 10:18 PM
Have you checked the oil dipstick for the oil level? Could be overfull if someone used the same amount of oil as usual, but, forgot the filter was not changed.

topsites
07-26-2011, 01:29 AM
Work smart, save yourself the hassle, seeing how you just end up having to do it over anyway,
if you're only going to do it half right don't do it at all, why bother and fuss going through all these motions,
save yourself a whole lot of work and aggravation, a job half done is only as good as a job that didn't get done at all.

You have no idea how I used to fuss just like you, trying to do something so I could say it got done, when I knew I wasn't going to
do it the way it was supposed to be done because I was too lazy... But stupid me, I could have just slept the afternoon away instead
of toiling away like a slave when in reality nothing ever got done right and then I'd wonder why it didn't work the way it should.

So now you know in the future, based on my own experience you only have to do something when you're ready to do it right.
Oil and filter, always.
No exception.

And anytime you're ready you'll need to change both the oil and the filter again, only this time try and do it right.