PDA

View Full Version : 29 dfi kawasaki on a scag tt


LilRabbit
07-25-2011, 09:06 AM
I have a scag turf tiger with the 29 hp Kawasaki fuel injected engine and a few weeks ago one of my guys ran it out of gas and I have been pulling my hair out since. It has been smoking heavy black exhaust when under a load and loose power, it won't idle for long and it will stall then hard starting. It seems to get worse the longer it runs and during these hot days it will even quit while mowing grass. I put new air filters on, changed the oil (I don't think there is gas in the oil, very little if any) new fuel pump which did improve things, plugs, and fuel filter, I have burned about 5 cans of sea foam, one can per tank. I took the top plastic fitting and hose off the top of the engine and the plate to the carb/injector and that had about a quarter inch of dirt that I cleaned off. I did take it to the shop and they said they would need a laptop and computer program to fix it??? and the sensors are between 3 and $500. Has anyone else had this problem or any input would be much appreciated Thank You

pugs
07-25-2011, 09:48 AM
Find a new shop. There is no computer program for Kawasaki DFI engines that I am aware of. All that Kawasaki offers is a harness that plugs in to both ends between the ECU and the engine and allows you to probe each wire with a meter to check for different things. And generally this is not necessary for diagnostics.

Now if it was a Kohler than yes there is a program and cable. Actually speaking of that I think I need to update my software for that one LOL.

LilRabbit
07-25-2011, 09:54 AM
ok thank you I will check around, have you seen anything like this before? any ideas?

TJ Property
07-25-2011, 05:22 PM
I had this same issue with one of my machines ended up being a clogged fuel line. Make sure you take the fuel line off and check that mine was clogged from grass and dirt some how.