PDA

View Full Version : John Deere 21S trimmer


MWHC
08-08-2011, 11:32 PM
We have a JD 21S trimmer giving me fits. The trimmer was running fine and stopped running. Have changed the plug, coil, fuel lines and cleaned the carb. I cant even make it pop. The compression is good. I do notice a lot of fues coming out of the muffler when I am pulling it a lot. Any Ideas where to look next?

Thanks.

dutch1
08-09-2011, 09:19 AM
I'm not familiar with the JD line so I don't know with what they might use for an antispark screen. It's possible that the screen may be carbon blocked. Remove the screen, if one exists, and burn the carbon from it with a torch. If this is the case, try starting the unit.

If you're convinced that the compression is adequate, confirm that you have spark at the plug. The most convenient is an in line spark checker. In the absence of a spark checker, first remove the plug and isolate the plug wire so that it will not create a spark around the spark plug port--you may have built up fuel in the cylinder as well as the crank case. Turn the engine upside down and crank the engine several times to assure that there is no excess fuel present then blow out cylinder and plug.

Reinstall, plug on plug wire and hold the plug base against the block, crank and check for spark. If spark is present, give the engine a shot of brake cleaner through the carb and determine if the unit will fire up for a brief time.

From your description, it is apparent that you're getting fuel and more than likely over fueling, possibly a result of the inlet needle not holding, a faulty check valve in the primer body or carb diagphrams with leaks.

dutch1
08-09-2011, 09:34 AM
http://jdpc.deere.com/jdpc/servlet/com.deere.u90490.partscatalog.view.servlets.HomePageServlet_Alt

Muffler parts breakdown showing screen in interior of muffler. If there is wetness and carbon buildup at the muffler exit, check this first. While you're at this point, you might also check for any blockage in the exhaust port of the head or associated parts.

MWHC
08-09-2011, 11:36 PM
Thanks. I will check the exhaust. This John Deere unit was made by Echo.
I have tried the carb cleaner in the spark plug and still cant get it to fire for a second. It has spark according to the inline check.