PDA

View Full Version : Stander wheel motor ????


TheBigGW
12-14-2011, 02:39 PM
I have had a leak of the hydro fluid and upon further investigation when i took off the wheel motor from the bracket a piece ring of flatten steel fell to the ground. I took pics of the piece and of the wheel motor. My question is i believe that i was leaking fluid from the cracked oblong piece of steel being in there. Since i removed it and cleaned and dried it, it has not leaked one drop at all where before it would drip slow with wheel on. I also took pics of wheel motor to show it and i believe i am missing a cover so is my wheel motor no good where else could i be leaking hydro fluid from its either the hoses or the wheel motor rite??????? Sorry for the long drawn out thread.... is there suppose to be a cover on the wheel motor just after the key stock or are you suppose to be able to see all the ball bearings inside thanks again gary

RickyDL77
12-14-2011, 05:48 PM
thats is probably part of the seal, and you can not get it from any one other than a Parker Hydrolic dealer, and good luck with that also. They have many divisions and seems none know what the other deals in. give me numbers off the end of the wheel motor and i might be able to get you a number for a seal kit. our standers 2005-2008 all use the same kit. here is a link with part numbers and where i get them from

http://www.lawnsite.com/showthread.php?t=339266

about half way down is a post with the pump numbers, part numbers and prices, and the location and phone number to where you can order the parts. with that seal bad it is best to totally take apart and rebuild being extra clean about it, just a little bit of dirt or lint from a rag can cause unwanted issues. And be sure to take apart and put back together exactly the same, it is easy to get mixed up if it's your first time.