PDA

View Full Version : Navigator Wheel Motor Leaking


CircleC
12-15-2011, 01:00 PM
I have an 08 Exmark Navigator, the right wheel motor is leaking hydro oil on a consistant basis. Also, the right hydro pump seems to be leaking a bit as well. On the hydro pump I dont see any dripping, but it does feel oily and is always covered in dirt. I have been going through about a quart a week.

Can you rebuild the motor and hydro pump. I have seen seal kits for both, but dont know how difficult it would be to rebuild. Mower has over 1900 hrs and I dont want to sprend a fortune on it with that many hours. Are the wheel motors side specific? Once I take wheel motor off and hydro oil drained, do I need to bleed the system to get it going again(might be a dumb question).

Over the winter I'm considering taking the thing apart and seeing what I can do. I dont want to take to Horizon...it will just cost me an arm and a leg!

Any advice and help would help.....thank

CircleC
12-15-2011, 11:04 PM
sooooo...does anyone have any expiereance with re-building wheel motors or hydro pumps...come on I know someone does

ed2hess
12-16-2011, 08:05 PM
I spend a lot of time at a repair shop and I guess I have watched them rebuild ten or more pumps and wheel motors. No way will lI try it way tooo many parts and keeping stuff clean is tough. In one case they put a wheel motor together and it didn't work so it was another tear down. It is almost sure that you need bearing as well as all the seals. A shop would be around a $1K. The parts would probably be close to $250 for the four.

TJLANDS
12-16-2011, 10:10 PM
It is one of the few things we will not do.
Replaced one wheel motor this year, was about $600
with labor and Warranty. Well worth it.
mower had 1800 hrs, now 2400.

CircleC
12-17-2011, 01:02 PM
Thanks guys....would you look around online and buy parts and do it yourself OR just take to dealer and get it done.

When you replaced wheel motor did you do hydro as well...thanks!

TJLANDS
12-17-2011, 01:08 PM
no just the wheel motor

CircleC
12-20-2011, 01:50 AM
Wheel Motor: Seems to leak only when sitting idle. When machine is running no oil leak..that I know of, I think I would have seen a few burn spots or turf damage if motor was leaking during mowing. When it sits on the trailer over night it leaves a nice puddle of oil. I had Horizon change fluid in the summer and did a flow test and it tested well. Has plenty of pulling power and turns good. Can it just be a simple seal or should I replace it?

bvillefarm
12-20-2011, 04:53 PM
I have rebuilt plenty of pumps on Exmarks, but I have not rebuilt any of the Hydro-Gear wheel motors that are used on the Navigator. Before you start tearing things apart, check the hydraulic hoses. I have had a few that leak right where the fitting is crimped onto the hose. On the navigator unit, the wheel motors are side sprecific, pumps are not.

ricky86
12-20-2011, 09:03 PM
The operating pressure is helping it seal. The seal you see is not the only seal in there.
The high pressure seal, which is the one that seal the hydro fluid is only accessible by
a complete tear-down. I wouldn't bother if it's a HydroGear. Parker's a fairly simple.
BUT, if it needs a shaft, it won't be cheap.

tallimeca
02-09-2012, 09:52 PM
have yet to see wheel motor on a navigator fail or leak. They are a little tricky compared to others because they are a reduction motor not commonly used in a standard Z. Have you tried pulling the wheel off and spraying to area down with starting fluid and blowing it off to see exactly where it's leaking?

Does your serial number start with a 5 or a 6?

I noticed some changes to the routing of the hydro lines back a few seasons ago. They started putting a protective sleeve around a couple of lines and the intake charge lines to the pumps when to crimped fittings and tees rather than worm gear clamps on nipples. I've seen some hoses weep from spots that were rubbing on the frame if it's before they put the sleeves on.

Also, on the bleeder valves on the pumps, there are o rings that tend to flatten out and allow fluid to weep buy. This is common on alot of the 10cc pumps but most of the time they are down where they get covered with crap and not a noticeable.