PDA

View Full Version : Walker Mower Hydro


Aussie12
02-12-2012, 11:30 AM
I have a Walker Mower Hydro pushing fluid back into the resivoir and causing it to leak out of the cap.... I have had this happen once before but I sold the machine without working out what was going on.... my initial thoughts are that something must be displacing the oil but what? ...... The hydro still works fine, pulls the same as the other side etc.

Anybody had this happen or any ideas what is going on? Any help appreciated.

Landrus2
02-12-2012, 11:52 AM
You can get a rebuilt kit for these units

ricky86
02-12-2012, 02:39 PM
I am assuming you have pumps and wheel motors.Does it look as if the oil is aerated? If so, it could be a leak on the suction side. Most likely you can't see it because it's sucking air in. To be sure, check the clamps (if equipped) on the suction side, or add clamps. Give it 20 min or so to clear the air from the system.

Aussie12
02-12-2012, 03:07 PM
I should probably have said that this is on an MTGHS 26 EFI around the 2000 model.

these hydro's are sealed units, there are no hoses or clamps to leak, the whole unit is filled with oil and there is a cup/resivoir on top that normally has a small amount of oil in it which rises a little when the unit is working and falls again when it stops.

fixer67
02-12-2012, 04:51 PM
how much are you putting in the resivoir ? you are ment to put only about 3/8 of an inch in the resivoir. The truth is it is not a resivoir. It is in fact an "expansion tank" and it will puke oil all over the place it gets hot if you fill it past the fill line at the bottom of the cup.


I am having computer problems is the reason I have not been on more

Aussie12
02-12-2012, 05:36 PM
I check them fairly regularly, they rarely need topping up.... I guess it is possible that I could have put a little too much in at some stage, if it was low, but I am aware of the level the are supposed to be at. If I did over fill it I imagine it would only push oil out until it reached the proper level.

This has been pushing oil out for a while now, probably a couple of months.... I just checked it now, the machine is cold and has been sitting overnight, the expansion cup is over half full, I doubt that I would have put that much in there.... would I ? ..... maybe I did :confused:

ricky86
02-13-2012, 12:33 AM
It didn't make oil. As stated, on the intergated hydro's, that's only an expansion tank.

Aussie12
02-13-2012, 02:13 AM
Yeah it cant be making more oil that's for sure..... maybe it was me putting too much in there:o... I will take some out to get it back to the full line and keep an eye on it :o

ricky86
02-14-2012, 08:56 AM
Make sure that full line isn't when hot. You should try to check a hydro when cold. The hot line is relative to ambient operating temperature. It could be at a different level for two different lawns. IMO

tyslawnservice
02-14-2012, 12:23 PM
hey
i have a 2000 walker 26efi 2500 hrs and both of mine leak as well maybe the cap seal needs replaced. allso i noticed that when i tighten "resivoir" cap on the right hand it unscrews the resivoir from the hydro must be back words threded? ill hopefully have time next year to take the hole thing apart and rebuild it(the walker)(if i have a shop by then).

Aussie12
02-14-2012, 04:39 PM
Yeah the cups are left handed thread into the hydro and if it isn't tight it could certainly leak from there.

I dropped the oil to the right level, and did about 2 hrs slashing, my oil level is still sitting at the right level in the cup so looks I must have overfilled it. :wall