PDA

View Full Version : Briggs Twin Fuel Pump won't pump


Rain Man av
03-14-2012, 01:13 PM
42A707 2653 E1, 17.5 HP Briggs twin cylinder engine.

Fuel pump is one of those four bolt ones. Replaced fuel line, fuel filter, installed new fuel pump kit. No matter what, it won't pump fuel. mower will run with starter fluid.

On the fuel pump body are two ports, one to the side, and one at the bottom, engine hose is connected to one on bottom, and fuel to one on side. Just a test, I reversed those and still no fuel pumping. Currently the fuel pump is apart. Carb is still on intake. I have the main body of the fuel pump in for a soak. I have sprayed all passages on pump and carb and it appears all are open. Both springs and diaphragms built in to the main fuel pump thingee are present.

I have another FP I could rob parts from, but before I take that one apart, I want to determine what is problem. I've worked on these before and have NEVER had this problem.

I need diagram to make sure I am putting the fuel pump together correctly. Also, if I am putting the FP correctly, then what could be causing not to pump ? Inquiring minds want to know.

:wall

Two planets are visible in the western sky they look spooky and they cannot be missed, unless it is cloudy or rainy or daytime or the moon is out or you are wearing dark glasses or if you are looking the wrong way.

Rain Man av
03-14-2012, 03:28 PM
turns out the plastic part of the fuel pump was clogged, after letting soak for several hours, I reinstalled it. It pumped gas and engine ran just fine.