PDA

View Full Version : 2008 Walker MT 20hp Fuel delivery problem


hvlawncare
03-20-2012, 08:18 AM
Ok I have a Model MT walker bought brand new in 2008 with a 20hp Kohler engine. As of yesterday my mower would not run. I replace the fuel filter and tested the fuel pump for vaccuum. I am not receiving any fuel from the tank. The tank is more than half full. I do not feel any vaccuum coming from the hose before or after the fuel filter. When I take the diaphram off the fuel pump, I have suction. Is there something I'm missing?

dutch1
03-20-2012, 09:23 AM
I haven't seen a Walker in a few years, but as I recall they have a drop line in the fuel tank. Check you tank for a faulty drop line--if it has deteriorated and fallen off, you may be sucking air.

Just a thought since I experienced the same problem with a few of the earlier Gravely Z-turns--different tank design but drop lines failed at the tank elbow fitting on the inside of the tank.

If that might be the problems, replace with Tygon line.

hvlawncare
03-20-2012, 09:28 AM
Thanks for the suggestion, but my drop line is working just fine. I blew air back through the line before the fuel filter to the tank to check for blockage. The tank started bubbling as soon as I started blowing air through the line.

My main issue is no fuel delivery to the fuel filter, which leads me to believe it's the fuel pump. However, like I said I took the fuel pump off and it seems to be correctly working. It's a two line pump. One line going in, one line going out. The out-going line is sent to the intake "dome." I have yet to check that side, I just don't believe that has anything to do with it considering I need to fuel tp the pump before the intake.

dutch1
03-20-2012, 10:02 AM
If the fuel line is cracked above the level of the fuel, the fuel pump will suck air before it pulls fuel.

hvlawncare
03-20-2012, 10:24 AM
Good thinking, but I replaced the lines earlier this morning with no result or change in situation. I'm heading back to check the solenoid for the fuel pump and see if that is the cause of my problem.

dutch1
03-20-2012, 11:37 AM
Engine numbers? Pull the carb fuel line off at the fuel pump then crank the engine--if fuel lines and fuel pump are good, you should have fuel.

piston slapper
03-20-2012, 12:19 PM
Pull the hose going to the fuelpump from the tank..
Attatch a mighty vac or suck on the hose....
If fuel comes out you nose...the fuelpump is bad.
If not..check some of the things Dutch recommended...
Posted via Mobile Device

fixer67
03-21-2012, 07:43 PM
Pull the drop hose out of the tank and look at it. All it takes is a pin hole in the hose for the pump to stop pumping. If that is OK then remove the fuel hose from the carb and put the end of the hose in something to collect the feul and turn the engine over with the key switch for about 5 seconds. Let starter rest for a minute of so and do it again. In you donot get any fuel then you have a bad pump or a pinched hose or blocked filter. Check the oil for gas. A lot of times when the pump goes bad on a Kohler CH20 it will pump gas into the vavle cover and into the crackcase.

hvlawncare
03-22-2012, 09:02 AM
Ok, I found a tear in the diaphram above the fuel pump. Big problem considering you have to buy the whole pump and not just the diaphram. I am hoping that the diaphram is the only problem and not something els all-together. Once I replace the fuel pump I will repost the results, thank you guys.

fixer67
03-22-2012, 07:08 PM
Warning====Read Kohler TT-5099. The notice will be in the box with the fuel pump/valve cover.

Shortcut to Kohler Service notes and manuals.
http://www.kohlerplus.com/model_group.asp?ModelGroupID=93#

Landrus2
03-22-2012, 07:15 PM
Ok, I found a tear in the diaphram above the fuel pump. Big problem considering you have to buy the whole pump and not just the diaphram. I am hoping that the diaphram is the only problem and not something els all-together. Once I replace the fuel pump I will repost the results, thank you guys.

How is that walker running

hvlawncare
03-24-2012, 03:54 PM
Fuel pump was replaced and it started right up. The new fuel pump looks slithly different with a oil valve cap for easy use I believe. Appreciate the help guys.