PDA

View Full Version : Shurflo Electric BP issue


DA Quality Lawn & YS
08-16-2012, 02:35 PM
For anyone who runs a Shurflo Electric BP.

Make sure you check the inlet screen that is located in the tank. Mine plugged up with junk and restricted flow on me. One caveat: this screen is HARD to get at. You can pop it out easy and clean it, but getting it back in forces you to put your arm in the herbicide tank to re-install. If you have any muscles at all, you cannot get your arm in the tank opening to do this. Not a good design IMO. Screen should be in the hose for easier access.

n-green
08-17-2012, 06:17 PM
I am not recommending this but I remove the screen after the first clog. Still get 2-3 seasons out of them. What a PITA.

LawnoftheMonth
09-17-2012, 03:20 PM
I just had to do this a hour ago, not cool at all.

Ijustwantausername
09-18-2012, 09:55 PM
Bump to the top!

Wanted to let everyone know that I saw these at a supply store - about 5 of them unopened each for $150. I think I might go back and get one for next year, my Hudson neverpump is a leaking piece of junk.

What did you pay DA?

RigglePLC
09-18-2012, 11:10 PM
Feel free to put a garden hose filter in the hose near the wand. Easy to clean.

DA Quality Lawn & YS
09-21-2012, 01:45 PM
Bump to the top!

Wanted to let everyone know that I saw these at a supply store - about 5 of them unopened each for $150. I think I might go back and get one for next year, my Hudson neverpump is a leaking piece of junk.

What did you pay DA?

$200 but that was a few years back. Don't get me wrong it is a nice unit but that screen placement is poor.