PDA

View Full Version : New Trailer and Brakes Won't Work


statman
10-06-2012, 05:41 PM
I just got a brand new trailer (storm lightening) and am trying to get the brakes to work with my 2008 Dodge Ram. Never have used this part of the tow package before and am not having any luck. Fuse is good. The controller had power to it, but I'm not sure it is on the correct wire. I using an aftermarket harness and a Primus IQ controller. Also the center top brake light on the trailer doesn't function.

Any help would be greatly appreciated

PlantscapeSolutions
10-07-2012, 01:38 AM
I just got a brand new trailer (storm lightening) and am trying to get the brakes to work with my 2008 Dodge Ram. Never have used this part of the tow package before and am not having any luck. Fuse is good. The controller had power to it, but I'm not sure it is on the correct wire. I using an aftermarket harness and a Primus IQ controller. Also the center top brake light on the trailer doesn't function.

Any help would be greatly appreciated

You need to buy a cheap multi meter and check for power at the trailer plug. There have been some issues with wires being crossed in trailer plugs as well. It may be easier to go to a trailer place. An experienced trailer guy will likely spot the problem instantly. They also have a plug in tool inspecting are wiring issues.

easy-lift guy
10-07-2012, 07:14 AM
Make an appointment to have the issue resolved from the place the trailer was purchased from or an authorized dealer only. You issue is a life or death one and needs to addressed ASAP.
easy-lift guy

statman
10-07-2012, 10:45 AM
Thanks guys

White Gardens
10-07-2012, 11:31 AM
I just got a brand new trailer (storm lightening) and am trying to get the brakes to work with my 2008 Dodge Ram. Never have used this part of the tow package before and am not having any luck. Fuse is good. The controller had power to it, but I'm not sure it is on the correct wire. I using an aftermarket harness and a Primus IQ controller. Also the center top brake light on the trailer doesn't function.

Any help would be greatly appreciated

If you've got one brake light out, then that's probably a factory wire on the trailer that is not working correctly.

For the truck-side, there could be multiple things. Some trucks, even with the tow package, might not have the red constant power wire for the brake-away controller installed. Or, if it is, sometimes it's disconnected from the power supply either by means of a simple fuse, or it isn't connected to the harness in the back.

Same goes with the blue brake wire. Sometimes it's there, just not connected into the harness.

But, I do agree. If you don't feel confident in getting it right, go to a dealer and have them look at it.


......

statman
10-07-2012, 04:30 PM
Thanks. i just found an unterminated blue wire coming through the firewall where the hood cable comes into the cab. It's coiled and taped up, not sure if it's a trailer wire or not.

White Gardens
10-07-2012, 08:21 PM
Thanks. i just found an unterminated blue wire coming through the firewall where the hood cable comes into the cab. It's coiled and taped up, not sure if it's a trailer wire or not.

More than likely it is the blue trailer brake wire.

Look on you tube, there are a lot of install companies that show how to videos for your specific truck. You'll get some good insight there.

The only other thing to look for, is if you have a break-away battery on your trailer, is to see if you have the red constant wire going into the truck-side trailer plug. If not, you'll need to run a hot-wire to there and hook it in to charge the battery every time you hook up the trailer.



....