PDA

View Full Version : No way to start the day


zechstoker
10-26-2012, 12:54 PM
This day is shaping up to be a real gem already. To get things started, I woke up a half hour late this morning, got ready in short order, left the house 10 minutes late, and then the clutch went out on the truck 15 miles down the road. So much for getting any work done. Looks like this F-150 gets to spend the weekend at the shop, which really stinks because we don't have another vehicle to haul the lawn gear.
Posted via Mobile Device

Sprinkler Buddy
10-26-2012, 01:22 PM
I had my neutral safety switch go out on my truck, been starting it with a screw driver on the solenoid until the part comes in. Haven't forgot to leave it in neutral yet. LOL Always something!

zechstoker
10-26-2012, 03:28 PM
False alarm with the clutch. Turned out to have just run empty of clutch fluid. Got that filled up, and now it's shifting alright. I thought it was something worse because it completely went out last year, and thought it was the same problem all over again.
Posted via Mobile Device

Patriot Services
10-26-2012, 03:33 PM
False alarm with the clutch. Turned out to have just run empty of clutch fluid. Got that filled up, and now it's shifting alright. I thought it was something worse because it completely went out last year, and thought it was the same problem all over again.
Posted via Mobile Device

Clutch fluid goes two places. Out through a leak or is lowered due to clutch wear.
Posted via Mobile Device

zechstoker
10-26-2012, 05:05 PM
Currently feels like there may still be a problem. It's shifting, but seems to require a little muscle to get it into gear. I just stopped at a Chevron to check fluid levels, and it hasn't gone down at all since it was filled up this morning. Not sure what's going on with this thing at this point.
Posted via Mobile Device

Sprinkler Buddy
10-26-2012, 05:08 PM
Running it out of Fluid may have caused a more serious problem. :-(

zechstoker
10-26-2012, 10:08 PM
Running it out of Fluid may have caused a more serious problem. :-(

That's what I'm afraid of. It was smelling like something was burning. That same oder you smell when something electrical is burning, but I can't tell what/where it's coming from. It's smelt like that since the initial breakdown this morning.
Posted via Mobile Device

Patriot Services
10-26-2012, 10:11 PM
Id say disc is down to rivets. Throwout is going and possibly a leak in the slave cylinder, line assembly.
Posted via Mobile Device

zechstoker
10-26-2012, 10:22 PM
Slave cylinder was the culprit last year when we took it in for repairs. I'd like to think that part's still good, but that's to be determined.
Posted via Mobile Device

jeannewyatt
11-04-2012, 07:51 PM
Sounds like you got air bubbles and are burning the clutch. Try bleeding the slave cylinder and you should be ok
Posted via Mobile Device