PDA

View Full Version : arbs turning brown


BDC
05-08-2003, 12:46 PM
I planted 5-6 ft arborvitae last fall along a parking lot. After a long winter, lots of plowing, and sanding the arbs show alot of brown area on them. I realize that in combination of bad winter and amount of sand/salt this isnt uncommon.Is there anything I can do to better the situation that would help? They are getting plenty of water from a wet spring, and I gave them a dose of holly tone fert. Thanks in advance for your help.:confused:

mdb landscaping
05-08-2003, 03:09 PM
i have been noticing some serious winter burn and salt injury over the past few weeks. i was just looking at a row of chinese junipers that are along a road, and they have serious salt damage....i thought to myself, whoever designed that landscape didnt think that out to well. as long as they get plenty of water and you fertilized, they should grow out of it and green up once warm weather is here. BTW, where in CT are you located?

BDC
05-08-2003, 03:50 PM
Thanks for the reassurance, Iappreciate the response. Ilive in Avon, where I operated my bussines for 8 years, now I work in New Britain at a residential treatment center for kids where I oversee 40 acres and perform all maintenance and work on grounds. Thanks again for your reply

bommaritro
05-08-2003, 04:01 PM
What type of fert plan do you recommend? I just picked up a contract where they have 20+ Arbs that are displaying the characteristics that you are talking about. They run between two driveways.(I will post pics later.) I am just getting into fert apps for shrubs and trees so I am not really sure what they need. If it was turf then no problem. Doing some research now but I figure that you guys can head me in the right direction.

Thanks,
Ron

BDC
05-08-2003, 04:15 PM
I generally use holly tone, but I have gotten as good as results with 10-10-10 general use fert.