PDA

View Full Version : kawi engines


turfguy
03-21-2004, 09:31 PM
I have asked this before but never realy got to the root of the problem. my 23 liquid cooled kawi always seems to be low on coolant. the resivor is always very low or empty and the radiator seens to have enough in it but where does it all go? my dealer has preasure tested the system twice and all seems well I preasure tested it overnight and it held up ............soooo where does the coolant go? another guy I spoke with said that his overflow tank was almost always dry...what gives ..any body else see there overflow tanks empty out for no reason?

grass_cuttin_fool
03-21-2004, 09:41 PM
Mine doesnt get empty, kinda low at times and i never see it on the floor and i have pressure tested my radiator also, I even had an oil analysis done and it came back with no trace of anti freeze. Just a mystery I guess, I have the 17 hp liguid cooled engine

premier lawn care
03-21-2004, 09:56 PM
I had the same problem w/ my 27. Just filled it up every once in a while and kept on mowing. My dealer never could find the problem.

johnbast3
03-21-2004, 10:05 PM
Leaky head gasket or intake,either way,you are burning the antifreeze..

dguffey
03-21-2004, 10:27 PM
My 27 does the same thing. I've always wonder whats up with it.

specialtylc
03-22-2004, 02:08 AM
Have your dealer call the Kaw. factory about this. That coolant is going somewhere. My guess is head/intake leak. You wouldnt notice any leak because the engine pulls it in the combustion chamber after the engine gets up to operating temp. I have had dealers look at something like that and just say it must be normal because they are lazy or dont know any thing. MAKE THEM CALL THE KAW FACTORY.

J.Gordon
03-22-2004, 06:15 AM
You might want to replace the radiator cap. I have seen a lot of caps that were defective right out the box. If they arenít keeping the pressure at the proper PSI The anti-freeze will evaporate. It would be a cheap fix if it were the problem! Just my .02
Jeff

ducky1
03-22-2004, 07:29 AM
You might want to check the water pump for leaks. It may be leaking so slow that it does not make a puddle on the floor or anything but it will have some stains around the gasket where it bolts on. You might have to look real hard because of where the pump is located.