PDA

View Full Version : Dixie Chopper not cutting so good


msd_woody
06-24-2004, 01:41 PM
My DC hasn't been cutting too nice this year. I just put on a new set of Gator blades today, lubed my deck up, made some adjustments, and it still isn't cutting like it used to. Off the left side of my deck, it seems to miss a narrow strip sometimes. When I trim around trees, wherever my deck wheels run, it doesn't pick the grass up high enough to cut it. And last, my striping doesn't look near as nice as it used to. My rear tire tracks are always darker and you can tell where each blade cut (I have 3 small stripes per pass instead of one 60" stripe). Any ideas what could be the problem? Does it matter which way blades are oriented when you put them on (not which side faces up, but how they are placed side by side)? Also, I have 2000 hours on the machine - is it possible the motor may be getting week and not providing me with the power I need to maintain the proper blade tip speeds?

Richard Martin
06-24-2004, 05:04 PM
There is nothing wrong with your mower as long as the belts are tight and you are maintaining a minimum of 3600 rpm engine speed. In our area the grass is tending to get "lazy" this year. There is still plenty of moisture like last year but what is falling is evaporating a lot faster than it did last year. Everybody I am talking to in my area is noticing that the grass is laying flat under the tires. Try taking the Gators off and putting Dixie Chopper hi-lifts on it. Right now I am running doubles on my 60" Dixie. Dixie hi-lifts on the bottom and Gravely 17" regular lifts on top.

Lawn-Scapes
06-24-2004, 11:08 PM
LOL.. One of the longest memberships I've seen with such a low post count :D Still considered a "new memeber" :p

I'm a semi-new Dixie Chopper owner and have had a love/hate relationship with mine. Today I really, really loved it! After 2000 hours on yours... you two should have a good understanding of each other :)

Ditto all that Richard said plus... how are your spindles holding up? Any play? Are the new blades straight? When you line 'em up under the deck (tip to tip).. are they exactly level? I have found some blades that haven't been and this led to an aweful cut... missing strips of grass.

Good luck... and post a little more frequently would ya!

leadarrows
06-24-2004, 11:21 PM
I had too take my Gators off this spring for the same reason. Putting the DC blades back on didn't totally solve it but it is cutting much better. I have noticed slowing down some helped as well. We have had a lot of rain here in central Indiana this year.

msd_woody
06-25-2004, 07:38 AM
I just took a set of hi-lifts off yesterday. The Gators seemed to work a little better but not much. 3600 RPM? I don't have a tach on my machine, but by guessing, I would say my motor is not turning that fast at full throttle. I guess I'll have to put a tach on and see. I noticed this morning, an area of shaded grass I did yesterday looks great. Everything I did that receives sunlight doesn't look so good. So, maybe it is the grass this year. That would make sense, because I have changed nothing on the machine or the way I mow the same places to have the cut not come out as good.

Goodguy001
06-25-2004, 11:08 AM
It is the grass!!!! All brands are cutting cr@ppy!