PDA

View Full Version : LazerZ ( Need Help)


Centerline Crosscut
07-07-2004, 05:40 AM
Ok here we go ! I started the company back in 1983, After a couple of years i then gave it to my brother. He is doing very well with over 100 acounts that he cuts a week. A few years back he left the area where we started the company. Customers were upset and would call all the time for us to come back and cut. So my brother gave me all his second hand equipment and i got started cutting back in that area. The help that i need is that, I sold all 3 Toro Wheelhorse mowers and bought a LazerZ 60 inch. The first one only had 1.3 hours on it and the wires fried in the harness. The dealer gave me a new mower no problem, yeah right. Got the second mower and it had an oil leak. Changed filter with no luck after 5 hrs. Took it back to them, and it took 5 days to repair. They replaced oil cooler. I cut last night and now i notice that when i make fast changes in directions the motor bogs down. Is this normal? The grass was not thick! This is a 27hp Kohler air cooled engine. Please help.

travis strecker
07-13-2004, 01:37 AM
u should post this in the lawn care one i drove one last year and it did the same thing

Patrick.B
08-31-2004, 08:26 PM
i got pm144z Gravely and it was doing that too..bought it to the dealer and theys check it out and couldn't fine anything wrong with it so what they did is change the fuel filter ..Never done it again after that ,,,,,think it has water in gas ..bout the only thing i can see ....Hope you fine the problem ....:)))

Centerline Crosscut
08-31-2004, 10:53 PM
The owners of weingartz and Exmark gave me a new mower. Thanks for the help