View Full Version : 50" Chopper

07-20-2004, 11:10 PM
Anybody else out there got a 50" Chopper?

Reason I'm asking is

1. I need a deck and

2. What's the deal with the deck wobblin' back and forth.

I've had this thing for a while now and I can't seem to get the deck tight and keep it level at the same time. I can adjust the chains so it's hanging even and eliminate the side to side play but then it's 1.5" out of level.

Anybody got a cure for this.......talked to another guy in town that has one and he said his does the same thing. His cure was to lower the air pressure in one of the rear tires to compensate!!!

Not the cure I'm looking for.


07-21-2004, 12:55 AM
Guess the 50" ain't too popular!

07-21-2004, 09:47 AM
Are you sure you have all the pins connected? I have a 50 inch and it doesn't do what you say. What year is it?

07-22-2004, 07:35 AM
All the pins are in place. Mines a 97 model.......and yes....there is some wear on it but I'm talking about being able to stand on one side of the deck and lift it 4"!

07-22-2004, 09:13 AM
do you have the manual? One thing to check would be the bars that run from the wheel motor housing to the deck. They are one inch square, make sure the end clevis's aren't too wide.

07-22-2004, 11:06 PM
I'll take a look at them tomorrow.........thanks for the tip.

Eric 1
07-23-2004, 08:27 PM
Mine does not move.

on thye front of the deck, on the right side facing the mower there is an adjustment to move the side of the deck,it is a small bolt, try that.

Hope this helps.

07-23-2004, 09:52 PM
I've adjusted the chains and even taken a link out of one side. When I get the deck tight it's way out of level. I haven't seen the bolt your referring to but I'll look again.

Eric 1
07-23-2004, 09:59 PM
Well being that mines newer it may have changed some?