PDA

View Full Version : power stroke wont start


bligh61
08-28-2004, 10:31 AM
i have a 1995 f250 7.3ltr power stroke. last week out of the blue it wouldnt start. right at the end of the day. changed fuel filter. let it cool and it started. then it wouldnt start again,just cranks. any ideas?

rkbrown
08-28-2004, 11:21 AM
Cam Position Sensor, possibly ? I know they go out on the 99 an up.

kc2006
08-29-2004, 12:40 AM
go to ford-trucks.com and read. Really good site. they have a forum just for the 7.3's

Sounds like a cam sensor. The CPS's go alot, the way to figure it out is if the tach doesnt move i think. Go to the site and do a search and it will tell you how to change it. takes a few mins and theres aplace you can get it for 80 bucks instead of 150 that the dealer wants or 300-400 for them to do 10 mins of work. Its a good thing to buy an extra and keep it with you because they go out whenever they want, it takes a 10 mm open end wrench to change it.

bligh61
08-29-2004, 10:57 AM
thankyou for the info. sounds like good advice. everyone has said pretty much the same thing!

lwcmattlifter
08-29-2004, 10:53 PM
You can get a CPS from International for around $90.

JRSlawn
08-29-2004, 11:23 PM
sounds like a frd to me :D

Grassmechanic
08-30-2004, 08:42 AM
I've never had a cps go bad on my powerjoke, but I sure had a few problems with glowplugs that would not allow it to start.

FrankenScagMachines
08-30-2004, 12:25 PM
go to www.thedieselstop.com and check there. it's a big Ford diesel forum board site just for Ford diesels of all models and variations and years. From the old 6.9 liter in the early 80's to the brand new 6.0's. very nice and helpful people there.

zpoore
08-31-2004, 08:55 PM
well if you get a cummins that will solve the problem. :D

xcopterdoc
08-31-2004, 09:22 PM
Fixed yet?? any luck?

bligh61
08-31-2004, 10:12 PM
not yet changed the cps and the oil , ill look at the injectorpressure regulator oring next

HayBay
08-31-2004, 11:14 PM
I have one and you better make sure your 2 batteries are fully charged before you throw money at parts. Just because its cranking it may be cranking too slow, the cps won't pick up right.

lwcmattlifter
08-31-2004, 11:26 PM
Something else to check is the IDM (injector drive module) and the PCM. Do you know of anyone it the area that has a similar truck you could trade IDM's with to see if thats the problem. Injector wiring harnesses are known to burn up under the valve cover and at the harness to cover junction. Do you have access to a code reader? What codes is it throwing? Hope this helps.

selnoil
09-02-2004, 08:11 PM
Mine died last year as I was driving. Turned over just fine but wouldn't start. I'm a pretty mechanical guy but had it towed to a local ford dealer. They called 2 hours later and said it was done, went down and it was the cam sensor. My point is that it cost less then $200 including the tow. It may be worth it to have a ford dealer check it rather then spending $$ and it still does not run.

kc2006
09-04-2004, 08:26 PM
he already replaced the cam sensor, they're all calling it a cps (cam position sensor) When my ICP was messed up it would start but idle real weird so i doubt its that. While your in there do the "10K" mod, go to that site i said and read about it, costs 25 cents and some say it adds 30hp and close to 100 torque.