PDA

View Full Version : Scag advantage help


bwallen149
10-04-2004, 06:24 PM
I have a 2004 wildcat, was thinking since the leaves are starting to fall that I would lower the "custom cut" baffle. When I did this the blade on the trim side of the deck would just barely hit the baffle. Has anyone else run into this problem. Sure made one heck of a bad noise when I turned the blades on. I thoght maybe I had a bent blade bolt so I swaped it made no difference. I think a couple of minutes with an angle grinder and I could solve the problem, but hate to do that to a 3 month old mower.

Sam-Ohio
10-04-2004, 08:46 PM
Why not contact your dealer, and let him see what is happening ?
What ever you do , DON"T TAKE A GRINDER TO IT, Let your dealer see what is interfering with the blade tip, and get it properly taken care of under warranty .

olderthandirt
10-04-2004, 09:09 PM
Why not contact your dealer, and let him see what is happening ?
What ever you do , DON"T TAKE A GRINDER TO IT, Let your dealer see what is interfering with the blade tip, and get it properly taken care of under warranty .
What are you talking about? Sound like an old man giving advise :D

Mac

odin
10-04-2004, 10:31 PM
Why not contact your dealer, and let him see what is happening ?
What ever you do , DON"T TAKE A GRINDER TO IT, Let your dealer see what is interfering with the blade tip, and get it properly taken care of under warranty .


Good advise sam ..could be something like a spindle under warrenty .

bwallen149 Have you checked to see if the blade it self might be bent?

bwallen149
10-04-2004, 10:59 PM
Odin, Yea I checked that. Actually switched blades and blade bolts thinking one might be bent.

sdwally
10-05-2004, 10:45 AM
On the 72" advantage decks we had problems with the mulching plates getting slightly bent from normal use. With the aid of our dealer we reinforced the exit baffle. Dealer now makes the modification on all our Scag mowers we purchase.
New design sent to Scag for evaluation. You guessed it, they adopted the modification and not even a thank you.
If you problem is on the plate that bolts onto the deck's discharge chamber let me know I can provide more info.