PDA

View Full Version : PECO Baggers Problem


JTurpin
05-24-2000, 12:12 AM
I have a Peco bagger on a JD Mid-Z. I bought the machine last fall and have thirty hours on it. It has been in the shop three times for engine problems. It has the Kohler Command 6hp engine. It run about thirty minutes then start stumbling for 10 mins till it quits. It blows black soot at that time it is stumbling. Everytime they say it my carb full of trash. New can, good fuel, but it still does it wonder why? Any kind of known problems on these type of engines? Also the Peco bagger latching mechanism from the operators seat lasted about 20 hrs. Now I have to use a screwdriver to try to get it shut. Called Peco and they sent a free shim that is supposed to align the latch to work correctly. They have a fix that cost $180. He said that the new design for the latch for 2000 is improved and they won't upgrade mine to the new design. $1500 for something that you have to take to shop every two days and use a screwdriver to get it to latch. Boy is that Quality! Any one else make a bagger for the Mid-Z type of mowers?

HOMER
05-24-2000, 07:10 AM
I bought a Trac-Vac with the same engine, have had no trouble with it so far. I don't know how yours latches but mine just hooks over the handle on the mondo sized garbage can behind me!<p>Good Luck<br>Homer

Sharon Callender
05-24-2000, 04:22 PM
I have 2 Kohler 6hp with the same problem you described. I took it back to the dealer they determined the gas caps were not venting. We put new gas caps on and it seemed to correct the problem hope this helps.