PDA

View Full Version : engine surging


lqmustang
12-17-2004, 05:16 PM
Maybe y'all can help me with this, guess I didn't pay enough attention way back when I took some small engine classes in high school. :rolleyes:

The 15 horse Kawi on my Scag WB started surging a the last couple weeks of cleanups. I've finally gotten back to it, and today I changed the air filter, fuel filter, and pulled the bowl to make sure it was clean. Buttoned it back up and I'm still getting the surging. What do you think I should check next? I'm thinking that pulling the carb and giving it a good cleaning is probably a good idea? Any other things to check before getting frustrated and letting the dealer fix it?

TIA

Carolina Cutter
12-17-2004, 07:08 PM
Breather, spark plug, ignition coil, or carb clean

Travis Followell
12-17-2004, 08:04 PM
There are many kawasaki's that have this problem. Kawasaki can't even foigure out whats wrong with them. They just say its normal for the engine to surge when there is no load on it. I would say to clean the carb and see if that helps. If its got many hours on it you probibly need to go ahead and rebuild the carb.

STAN1366
12-19-2004, 12:09 AM
I believe the surging is caused by a lean condition. Clean the carb out and if that doesn't help then richen up the mixture by turning the screw out 1/4 turn for starters.

richard coffman
12-19-2004, 02:39 AM
Breather, spark plug, ignition coil, or carb clean

I'd go with this idea. how old is your engine. I've got a 15 horse kawasaki v-twin that's only got 1 adjustment screw on top. check your gaskets around the machine, may have a leak. replace the spark plugs and gapping to specs may help with problem. don't forget to torq bolts to specified specs.

respectfully,

Richard/Owner

Richard Martin
12-19-2004, 04:57 AM
Before you tear the carb apart try a different octane fuel. If you're running 87 octane try 89 or if you're running 89 try 91. The Feds make the gas companies do things to gas at this time of year and it's not always good for our small engnes.

easycareacres
12-19-2004, 05:46 AM
I had this prob twice, answer was a butterfly pin in carb. $27.00 in usa $ 140 australian. I was using an additave in fuel and not sure but think could have been result to new pin.