PDA

View Full Version : 7.3 PSD Coolant Problem


Lawnchoice
12-20-2004, 07:12 AM
Checked the coolant level today and found something very bad.

It looks like oil and is just as thick.

My first thought was the head gasket. The oil doesn't show any signs of coolant in it which is a good thing.

It's a 97 with only 80k.

Any ideas of what it might be?

grass_cuttin_fool
12-20-2004, 07:37 AM
Its been a few years since I worked on them, but it may be an oil cooler, One year back in the late 80's(and a 6.9) had a bad bunch of them and they were simple to fix, actually it was harder to clean the system of all the oil

lwcmattlifter
12-20-2004, 08:27 AM
Without looking at it my guess would be the oil cooler has a bad o-ring. The o-rings are cheap to replace. The oil cooler is behind the oil filter housing on the drivers side of the block. Take of the housing and you can remove the o-rings and inspect them. The other thing could be cavitation of the cylinder walls but that is unlikely with Powerstrokes because they have thicker cylinder walls than the earlier non turbo 7.3's and 6.9's. Have you been keeping the right amount of SCA treatment in the cooling system?

Lawnchoice
12-20-2004, 08:36 AM
Without looking at it my guess would be the oil cooler has a bad o-ring. The o-rings are cheap to replace. The oil cooler is behind the oil filter housing on the drivers side of the block. Take of the housing and you can remove the o-rings and inspect them. The other thing could be cavitation of the cylinder walls but that is unlikely with Powerstrokes because they have thicker cylinder walls than the earlier non turbo 7.3's and 6.9's. Have you been keeping the right amount of SCA treatment in the cooling system?

Thanks for the info.

I always keep up on everything and that is why I was shocked when I saw the fluid in reservoir.