PDA

View Full Version : kenwyn


kenwyn
02-17-2005, 07:28 PM
Could someone please help.
My John Deere JX85 ran very low on fuel and since filling and restarting seems to have a fuel problem. It appears like as if there might be a blocked power jet or something like that. (It runs OK at low revs.)
An outline of where to head for in the carburetor would be appreciated.
Thank you,
Regards, Kenwyn.

jimslawns
02-17-2005, 07:32 PM
If you ran low on fuel, chances are you have plugged up your in-line fuel filter, try replacing it first. A extremely low tank of fuel will let the pick-up line inside the tank pick up some of the debris in your tank.

kenwyn
02-17-2005, 07:42 PM
Thanks Jimslawns.
I haven't got the mower here to check. Is it an external fuel filter or one built into the tank?
Thanks a lot,
Kenwyn.

jimslawns
02-17-2005, 07:45 PM
should be inline, between the tank and the carburetor.

specialtylc
02-17-2005, 07:54 PM
We used to have a JX85 with the Kawi engine. It was very common for the main jet to get pluged on it. The Kaw carbs had a really small jet opening. After it happened a couple of times we put an inline filter on it which stopped most of the carb troubles.

stumper1620
02-17-2005, 08:16 PM
We used to have a JX85 with the Kawi engine. It was very common for the main jet to get pluged on it. The Kaw carbs had a really small jet opening. After it happened a couple of times we put an inline filter on it which stopped most of the carb troubles.

might have had a touch of water in the fuel, shine a flash light in the filler and see if there are any water bubbles in the bottom of the tank. :D