View Single Post
  #3  
Old 06-13-2009, 08:19 PM
DT Lawn Care's Avatar
DT Lawn Care DT Lawn Care is offline
LawnSite Senior Member
 
Join Date: Jul 2008
Location: Grand Rapids, MI
Posts: 850
Sounds like your wheel drive belts are out of adjustment, and probably your right brake too.

On most WBs you can take out a pin at the handbrake, and loosen or tighten the connecting rod to adjust the tension on these. If this doesn't fix it, check the tension on the belt from the motor to the trans (under the frame). It should be REALLY tight in order to work well. If that's loose, that could very well be the problem with that.

As for adjusting the brakes, I'm not sure on a Lesco, but it should have a wingnut or just a nut that you can loosen or tighten to adjust them.

As well as your deck belt, if you haven't tried to tension it, try that. If you have tried that and you need a new belt, take it to your hardware store or I personally would go to Napa. Unless it is some really weird belt, a standard V-belt should suffice.

Good Luck
__________________
'03 Chevy Silverado 2500HD 4x4 6.0L Utility Truck
'99 Ford F350 4x4 7.3L Diesel 11' Dump Truck
'07 Interstate 7' x 16' Trailer
'06 Exmark TT 60" Kohler 20hp
'06 Exmark TT 60" Kawasaki 22hp
'04 Ferris 52" Kawasaki 23 hp w/ Trac Vac
'98 Exmark Metro 36" Kawasaki 14 hp
Toro 21" Proline Mowers
Kawasaki Trimmers
Redmax Blowers
Shindaiwa LE261 Edger
Stihl KM110 Powerhead with attachments
Kawasaki Hedge Trimmer
Reply With Quote
 
Page generated in 0.03701 seconds with 7 queries