View Single Post
  #31  
Old 03-29-2010, 07:21 AM
topsites topsites is offline
LawnSite Fanatic
 
Join Date: Mar 2005
Location: Richmond Virginia
Posts: 21,677
Strange, I've got a 2003 srm-260s with at least 3 years full-time use to it,
and I don't recall ever replacing the carburetor.

I also find it odd, that story of the "new" carbs was going on back then as well...
Makes me wonder just how long this supposedly "new" design has been around?
But no, to my understanding they can not be adjusted, however this is rarely the problem even on carbs that can be...

Just strange they'd have to replace the carb, twice.
I suspect a faulty coil, which is the LAST thing the dealer wants to replace as to my
understanding they carry a lifetime warranty.

Oh, one more thing: DEMAND your old parts!
Anytime a dealer replaces something, before (or at the time of) dropping your equipment off,
make SURE to tell them, YOU want your old PARTS!
Otherwise they'll tell you they threw it in the garbage, gone...
They're not supposed to, anytime a customer requests old parts they should still have them, but what can you do?

How do I know...
My trimmer sat for 2-3 years not running right, all the while getting dumb looks at the dealership,
in the end it was the coil and I went through a bit of trouble to get them to fix it!
Yeah, now that's on top of it being me who had to figure it out, that trimmer sat in their shop for months on end.

Not saying that's necessarily the problem here, but it could be.

Quote:
Originally Posted by LwnmwrMan22 View Post
If it runs when it's cold, then starts to bog when it's hot, it's because the exhaust can't escape the engine.
To my understanding when it does that it's usually the coil!

Last edited by topsites; 03-29-2010 at 07:30 AM.
Reply With Quote
 
Page generated in 0.03742 seconds with 7 queries