Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
Reply
 
Thread Tools Display Modes
  #1  
Old 08-03-2001, 05:04 PM
dfor's Avatar
dfor dfor is offline
LawnSite Senior Member
 
Join Date: Dec 1999
Location: So. New England
Posts: 845
Elec. hedge trimmer problem

I have a set of Little Wonder electric hedge trimmers that quit working today while trimming. I could hear them slowly starting to lose power. Then just quit. Anybody know what might be the problem? I'd just like to get a heads up before bringing them in to be fixed. Maybe I'll be able to do it myself with help from you people. Thanks.
Reply With Quote
  #2  
Old 08-03-2001, 05:11 PM
thelawnguy thelawnguy is offline
LawnSite Silver Member
 
Join Date: Dec 1999
Location: Central CT
Posts: 2,412
Check the brushes? Two large screws on either side of the motor.
Reply With Quote
  #3  
Old 08-03-2001, 05:58 PM
75's Avatar
75 75 is offline
LawnSite Senior Member
 
Join Date: Feb 2001
Location: Orillia On (Canada)
Posts: 992
Were they "gradually losing power" over a long period of time, or just during the round of use when they died?

Either way, checking the brushes as Bill suggests should be easy to do yourself. Relacing them should be a simple job if that turns out to be the problem.

Only snag you might run into is where to order replacement ones - not sure what you have in your area for power tool/electric motor repair places.
Reply With Quote
  #4  
Old 08-03-2001, 08:32 PM
Grapevine Grapevine is offline
LawnSite Member
 
Join Date: Nov 2000
Location: Massachusetts
Posts: 126
It's probably the brushes like these guys say, but also check the cord. A lot of times with all the pulling and twisting the connection can come loose in the handle. I like the Echo hedge trimmers because they're lighter than the gas and cut well, but I usually go through them about every 2 years and buy another set. I have 2 small Mantis pruners, 1 Echo, 1 Little wonder (all electric) I finally bought 2 Stihl gas hedgers because I was tired of my guys constantly cutting through the cords.
__________________
Grapevine Landscape
Reply With Quote
  #5  
Old 08-05-2001, 07:35 AM
dfor's Avatar
dfor dfor is offline
LawnSite Senior Member
 
Join Date: Dec 1999
Location: So. New England
Posts: 845
I only noticed loss of power on the day they quit, but it may have been longer. In any event, $6 and a new set of brushes, they are back up and running. Thanks for the help.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 06:16 PM.

Page generated in 0.07419 seconds with 7 queries