Register free!

The Green Industry's Resource Center



Reply
 
Thread Tools   Display Modes
  #1  
Old 11-19-2001, 11:34 PM
williamslawn williamslawn is offline
LawnSite Member
 
Join Date: Mar 2001
Location: SC
Posts: 202
SCAG Hydro Problems

My 1998 Scag Turf tiger was making a noise out of the LH Hydro pump. We tore it down and did not find anything wrong. It would also quit pulling when the fluid got hot. I changed the filter and fluid and put it back together. Now I cannot get the air out of the system. Any suggestion would help. Also put new gaskets and o-rings.
Reply With Quote
  #2  
Old 11-29-2001, 02:04 PM
rja rja is offline
LawnSite Member
 
Join Date: Jan 2001
Location: NJ
Posts: 25
I have not torn down the hydro system, but I have added the cooler package and replaced the oil and filter a number of times. The only time anything strange happend was after the first oil change. When I started to move the machine, it made a strange noise. This quickly went away and everything was fine. I think that I did not let it idle long enough before trying to move it and the oil had not fully circulated leaving some air in the drive motor. I would check with your scag tech.

Rich

On edit. the machine is a 1999 turf tiger
Reply With Quote
  #3  
Old 11-29-2001, 02:31 PM
CT18fireman CT18fireman is offline
LawnSite Senior Member
 
Join Date: Nov 2000
Location: Brookfield, CT
Posts: 610
If the fluid level is right then you need to get fluid into the rest of the system. We always just rocked the controls back and forth until the fluild was fully circulating. The system will be noisy until this happens. I would not worry about the noise. Also you should know that those pumps are pretty strong IMO. I have replaced many more greasshopper pumps then scags.
Reply With Quote
  #4  
Old 11-29-2001, 09:54 PM
williamslawn williamslawn is offline
LawnSite Member
 
Join Date: Mar 2001
Location: SC
Posts: 202
Took it to my Scag dealer. He tore it down 3 times and could not find out what was wrong with it. He finally had to put a new one on and now after $550.00 it is fixed.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 09:49 PM.

Page generated in 0.06799 seconds with 7 queries