Register free!

The Green Industry's Resource Center


 
 
Thread Tools   Display Modes
  #1  
Old 05-29-2012, 08:34 PM
ncbowhnter ncbowhnter is offline
LawnSite Member
 
Join Date: Mar 2011
Location: sanford nc
Posts: 18
2011 Super Z died on me while cutting???

I have a 2011 Super Z Hyperdrive with roughly 150 hours on it. A few weeks ago while cutting the blades quit, then started back, then quit again. Then the mower died. I tried to start it back but it would just click when I turned the key. I noticed a little corrosion on the positive battery post so I cleaned it the best I could and then jumped it off. It did ok for about 2 minutes and then the exact same thing. I got it home, thoroughly cleaned the battery posts and put it on a battery tender and have not had a problem since.
I didn't really think anything of it until my buddy called me yesterday and his did the exact same thing. His has about 350 hours on it. Neither of our dealers have a clue why they did it...
anyone have any ideas? thanks for the help in advance.
  #2  
Old 06-04-2012, 12:45 PM
mowerconsultant's Avatar
mowerconsultant mowerconsultant is offline
LawnSite Fanatic
 
Join Date: Feb 2000
Location: Syracuse, NY
Posts: 9,755
A couple things to check...
Make sure the engine is putting out the volts and amps, check this with a voltmeter, start the mower, run it at full throttle and measure the volts and amps at the battery posts.
It could e a bad battery also, need a set of readings off the battery with the engine not running, then may need a load test done.

Pj
__________________
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Layout Style:





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.com™ - Moose River Media
All times are GMT -4. The time now is 12:47 AM.

Page generated in 0.06848 seconds with 7 queries