Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
Reply
 
Thread Tools Display Modes
  #1  
Old 06-19-2012, 10:19 PM
Albery's Lawn & Tractor's Avatar
Albery's Lawn & Tractor Albery's Lawn & Tractor is offline
LawnSite Bronze Member
 
Join Date: Jan 2007
Location: Denver, CO
Posts: 1,675
Truck issues, need help

I have a '03 Dodge 3500 w/ 5.9 cummins, truck has 150K miles. Truck now seems to have no power, can't pull an empty trailer without wanting to over heat. New transmission, flushed radiator, new water pump and thermostat, no check engine light. No oil in the turbo intake. Any thoughts of what this might be?
Reply With Quote
  #2  
Old 06-19-2012, 11:24 PM
Tizzy Tizzy is offline
LawnSite Senior Member
 
Join Date: Jul 2011
Location: Connecticut
Posts: 363
fuel system issue? did you do any diagnostics on the fuel system.
Reply With Quote
  #3  
Old 06-19-2012, 11:40 PM
AEL's Avatar
AEL AEL is offline
LawnSite Bronze Member
 
Join Date: Oct 2009
Posts: 1,535
Check your lift pump.
Posted via Mobile Device
Reply With Quote
  #4  
Old 06-20-2012, 12:32 AM
Albery's Lawn & Tractor's Avatar
Albery's Lawn & Tractor Albery's Lawn & Tractor is offline
LawnSite Bronze Member
 
Join Date: Jan 2007
Location: Denver, CO
Posts: 1,675
But would the lack of fuel cause the truck to want to run hot?
Reply With Quote
  #5  
Old 06-20-2012, 01:04 AM
turboawd turboawd is offline
LawnSite Member
 
Join Date: Dec 2005
Location: midwest
Posts: 221
did an intake boot pop off by chance?
Reply With Quote
  #6  
Old 06-20-2012, 07:55 AM
bobcat_ron's Avatar
bobcat_ron bobcat_ron is offline
LawnSite Fanatic
 
Join Date: Nov 2007
Location: Abbotsford, British Columbia
Posts: 9,927
Head gasket or thermostat?
Posted via Mobile Device
Reply With Quote
  #7  
Old 06-20-2012, 12:49 PM
AEL's Avatar
AEL AEL is offline
LawnSite Bronze Member
 
Join Date: Oct 2009
Posts: 1,535
Caused my 06 to run hot . Installed an aftermarket fass150 and it was way better , not to mention way better filtration.
Posted via Mobile Device
Reply With Quote
  #8  
Old 06-20-2012, 11:24 PM
LuckyFlyinROUSH LuckyFlyinROUSH is offline
LawnSite Member
 
Join Date: Sep 2011
Location: MO
Posts: 36
Sounds like major boost leak. PSI normal? Fuel pressure good?
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 09:53 AM.

Page generated in 0.07787 seconds with 7 queries