Go Back   LawnSite.comô - Lawn Care & Landscaping Business Forum, Discuss News & Reviews > Sponsor Forums - Discuss with Sponsors Directly > Lawn Mowing Equipment & Accessories * * * * SPONSOR FORUMS > Hustler Turf Equip
User Name
Password
Home Products Find a Dealer News About Us Contact Us Mark Forums Read


Hustler Turf Equip Lawn Mowers & Turf Care Equipment

Reply
 
Thread Tools Display Modes
  #1  
Old 09-14-2012, 09:51 PM
Bunton Guy's Avatar
Bunton Guy Bunton Guy is offline
LawnSite Bronze Member
 
Join Date: Sep 2001
Location: charlotte nc
Posts: 1,652
Low oil light

Bought a brand new hustler trimstar 54" with kawasaki electric start engine

After the first hour of use the low oil red light came on while parking the mower. I let it sit for 30 minutes then checked the level....and it was right at the "add" line Hopefully that didn't hurt the brand new motor?

I added fresh oil and on my way I go....30 minutes later im done mowing and I bring the engine down to idle and the red light comes on again. I do the same and check the level and it was right at full mark. I then tested it and everytime I brought the throttle up the light went out. Bring the throttle back down to idle and the red light comes on.

Now im sure I would need to bring the mower into the dealership but I already have bad blood with the dealer. He is the closest Hustler dealer to me but he turns away most of the "warranty" issues I have had with my other Hustler super Z telling me that " hustler won't fix that under warranty" I've complained about 3-4 other things that have had issues with that should be under warranty and he denies all of them. Im sure whatever is wrong with this mower now I will be covering out of my own pocket.

What could this be? Mower has right at 4 hours on it now.
Reply With Quote
  #2  
Old 09-16-2012, 01:00 PM
hustlermidwest hustlermidwest is offline
Sponsor
 
Join Date: Sep 2012
Location: Chicago, Ill
Posts: 613
The good news is the low oil sensor is working. It was wise for you to watch your oil level on your unit. All new engines will burn a little oil until the rings sit and the engine is broken in. Be sure you check your oil level using the manufacturer guidelines found in your engine manual. Not all guidelines are the same. Assuming the machine is on level ground with proper oil level I would next look at RPM's. Your idle RPM's might be set too low not allowing the oil pump to run as fast as it should. Regardless, you need to bring the mower in for service. The issue sounds more like a Kawasaki issue and not one caused by the mower manufacturer. Warranties are for manufacturer defects, can't think of a reason this would not be covered.
Reply With Quote
  #3  
Old 09-17-2012, 12:37 PM
ACSMOD11 ACSMOD11 is offline
LawnSite Member
 
Join Date: Oct 2009
Location: Corning, IA
Posts: 17
Low Oil Pressure Light

Mine did the same thing, took it in and the deal checked the oil pressure at idle and full throttle and it was out of spec on both end. Ended up putting a new old pump in. Works fine now.
Reply With Quote
  #4  
Old 09-18-2012, 07:46 AM
Bunton Guy's Avatar
Bunton Guy Bunton Guy is offline
LawnSite Bronze Member
 
Join Date: Sep 2001
Location: charlotte nc
Posts: 1,652
ACSMOD11 & hustlermidwest: I understand this is a kawasaki issue and not a hustler issue. One of my main concerns is if the motor is now hurt due to low oil pressure a few times?

I would hate to know that if the engine had an effective life of 2,000hrs. that it now has been reduced to 500hrs. if you know what I mean.
Reply With Quote
  #5  
Old 09-18-2012, 11:05 AM
hustlermidwest hustlermidwest is offline
Sponsor
 
Join Date: Sep 2012
Location: Chicago, Ill
Posts: 613
Because of your quick attention to the oil level and the fact the light only went on at idle I don't believe you will have an issue down the road. It is something that you should get addressed asap at your Authorized Kawasaki dealer.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 08:46 PM.

Forum Rules:

This hustlerturfequipment.com sponsored forum is administrator monitored. LawnSite.com does not allow any manufacturer competitor attacks and will strongly enforce this. If you want your discussion to be viewable by the public and responded to in a professional manner then please keep your discussions professional and to the point.

All discussions are viewed by the administration before being released to the public. Your post may not be made viewable for up to 48 hours. Please allow the manufacturer representative enough time to respond to your question or comment once made viewable.

LawnSite.com is not affiliated with the Excel Hustler company. This forum is provided by LawnSite.com to Excel Hustler in order to better server their customers


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
Lawnsite,  Plowsite, WeldingWeb, LawnCareSuccess, Everythinggreen, & Lawnbusiness.net are trademarks of Lawn Care Success, Inc

Page generated in 0.06018 seconds with 7 queries