Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
Reply
 
Thread Tools Display Modes
  #1  
Old 06-21-2013, 10:19 AM
Prestige-Lawncare's Avatar
Prestige-Lawncare Prestige-Lawncare is offline
LawnSite Senior Member
 
Join Date: Apr 2006
Location: Central Indiana - GO COLTS
Posts: 753
New Clutch

I just had a new clutch put on my Hustler Super Z. All is fine now except for one thing I noticed. The fan that runs when the key is on, but the mower is not running .. doesn't run any longer. I checked the fuse for this, and it is not blown. Did they forget to hook up a wire or something?
__________________
.
I use Xtreme Series Racks, the most advanced racks on the market. Check them out at: TrailerRacks.com



Proud Supporter of:
Hustler mowers ~ Xtreme racks ~ STHIL products
Reply With Quote
  #2  
Old 06-21-2013, 06:16 PM
Sharpcut 1's Avatar
Sharpcut 1 Sharpcut 1 is offline
LawnSite Senior Member
 
Join Date: Sep 2006
Location: Roseville, MI
Posts: 450
Under the spoiler, white plug with 2 wires. Make sure it's plugged in. Red dash light working?? If this is a newer 2011 and up Hyperdrive Super Z, fan should'nt come on till after it has run for 1.5 minutes.
Reply With Quote
  #3  
Old 06-21-2013, 06:21 PM
Prestige-Lawncare's Avatar
Prestige-Lawncare Prestige-Lawncare is offline
LawnSite Senior Member
 
Join Date: Apr 2006
Location: Central Indiana - GO COLTS
Posts: 753
It is a 2007 model .. and I don't believe the red light is working. I will check the wire you mentioned .. I kind of figured it was something like that. I figured I would see if I could find it myself (with help on here) rather then driver back to the dealer that fixed it.

And yes .. the fan only ran I believe after I had had the mower running for a while.

Thanks ...

Dave
__________________
.
I use Xtreme Series Racks, the most advanced racks on the market. Check them out at: TrailerRacks.com



Proud Supporter of:
Hustler mowers ~ Xtreme racks ~ STHIL products
Reply With Quote
  #4  
Old 06-21-2013, 10:54 PM
herler herler is online now
LawnSite Gold Member
 
Join Date: Apr 2012
Posts: 3,614
Do me a favor...

After you get the mower running, go ahead and grab the old clutch and put two powered 12v leads to it.
If it clicks, it wasn't bad.
And still isn't.

Don't throw it away until you find out.
Reply With Quote
  #5  
Old 06-22-2013, 04:43 PM
A&R Enterprise A&R Enterprise is offline
LawnSite Member
 
Join Date: Jan 2010
Location: Easley,S.C.
Posts: 96
you might want to check the relay for the fan.This went bad on mine.
__________________
48'' toro z master
Quick 36 single
48'' hustler walkbehind
BR 600,Shindy eb 802,pb770
fs 90 r,km 90r,km100
9 hp little wonder push blower
19t ,310 stihl saws
tiller,chainsaw,edger,hedge clipper Kombi- attachments
hs 80
2003 F-350,7.3 on STEROIDS
24 ft enclosed trailer
7x14 ft Dump trailer
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 06:33 AM.

Page generated in 0.07098 seconds with 7 queries