Register free!

The Green Industry's Resource Center



Reply
 
Thread Tools   Display Modes
  #1  
Old 06-03-2001, 01:51 AM
gogetter gogetter is offline
Banned
 
Join Date: Jan 2001
Location: Yardley, PA.
Posts: 3,256
Husky edger vibrating!!

Just received my new Husky stick edger (model ex350, I think?). Starts fine and all, but REALLY vibrates alot until I squeeze the trigger then smoothes right out.
Normal? Never owned Husky equipment before.
Thanks.
Reply With Quote
  #2  
Old 06-04-2001, 07:22 PM
sdwally sdwally is offline
LawnSite Senior Member
 
Join Date: May 2001
Location: San Diego, CA
Posts: 385
You should check back with the dealer to be sure, this way it will be covered under warranty if there is a problem. You might try having the dealer start another new one to see if it does the same thing. Sorry I could not be of more help. We only have Husky chainsaws and 2 blowers.
__________________
Clay Walsten
ET III
Developed Regional Parks
City of San Diego

We enrich lives through quality parks and programs.
Reply With Quote
  #3  
Old 06-04-2001, 09:51 PM
TJLC TJLC is offline
LawnSite Bronze Member
 
Join Date: Jul 2000
Location: Port Charlotte, FL
Posts: 1,308
I had a similar vibration problem on my Echo. I figured out that the blade was bent. I flipped it over and it seems to have cured the vibration. Hope this helps.
Reply With Quote
  #4  
Old 06-04-2001, 11:32 PM
gogetter gogetter is offline
Banned
 
Join Date: Jan 2001
Location: Yardley, PA.
Posts: 3,256
Can't take it back to the dealer. Well, probably not for free. It was one of those e-bay deals.
But I'll check the blade.
Thanks.
Reply With Quote
  #5  
Old 06-05-2001, 11:39 PM
Island Lawn Island Lawn is offline
LawnSite Senior Member
 
Join Date: Dec 2000
Location: Golf Coast, SC
Posts: 632
Changing the blade has solved vibration problems for me in the past.
Reply With Quote
  #6  
Old 06-09-2001, 03:38 PM
gogetter gogetter is offline
Banned
 
Join Date: Jan 2001
Location: Yardley, PA.
Posts: 3,256
not the blade...

Just dawned on me. It can't be the blade because it vibrates at idle. The blade doesn't turn at idle. As soon as I squeeze the trigger, the blade goes and the vibrating stops.
I'll take it to a local shop. Thanks for the input though.
Reply With Quote
  #7  
Old 06-10-2001, 02:52 PM
SMB's Avatar
SMB SMB is offline
LawnSite Senior Member
 
Join Date: Jun 2000
Location: Southwest VA
Posts: 323
2 cycle engines do not run well at low RPMs. It may just be running rough at a very slow idle. My Shindy T270 vibrates at idle.
__________________
2004 F-350 4x4 6.0
2008 Bob-Cat ZT225
2001 Bob-Cat 48" WB
2000 Bob-Cat ZT219
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 04:50 AM.

Page generated in 0.07565 seconds with 9 queries