Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 06-23-2007, 09:58 PM
Michael.Sammons Michael.Sammons is offline
LawnSite Member
 
Join Date: May 2007
Location: Sandy Hook, Kentucky
Posts: 12
Need HELP on 17 hp Briggs I/C motor

I have a 42inch cut Craftsman LT1000 with a Briggs 17 Hp I/C motor that I believe may have expired. I'll be checking tomorrow to see if the piston is moving. I was mowing and it suddenly began blowing oil smoke. I shut down and found that I had over filled the oil. But then after letting it cool, Draining oil to proper level, it wouldn't start back. I had difficulty getting it to shut off, It wanted to continue to run, even with key off and choke on. It finally shut off. One repair man told me to check the pushrods. I pulled the valve cover and watched the valves work as I cranked the motor, So I don't think it's the valves/rockers/or pushrods. I think started thinking it may be the timing key, so I started pulling the top of the motor apart, I got to the flywheel and the key that is visible, looked ok. My father-in-law checked the carb and ignition system. It gets gas and is getting fire to the plugs. So what do I check next? Where is a good source for a rebuild kit if I need to go that route? It's a 5 year old mower, but I can't afford to junk it and buy new. Any help is greatly appreciated.
Thanks
Mike
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 04:37 PM.

Page generated in 0.10010 seconds with 8 queries