Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
Reply
 
Thread Tools Display Modes
  #1  
Old 09-08-2007, 01:06 PM
DSIM's Avatar
DSIM DSIM is offline
LawnSite Senior Member
 
Join Date: Jul 2004
Location: Arlington, Texas
Posts: 437
Stihl FC75

My Stihl edger just recently developed a problem after 4 or 5 years. It will start up and run for a short time with no problem, but when running for at least 10 minutes and then shut off, it will not start again until cooled off. Also yesterday I had several houses in a row and after the edger got hot, it just quit running.

Was wondering if this would be a carb problem or ignition?

Could it be the coil?

I bought a used Stihl fc110 on ebay last night. Can't wait to get it.
thanks for any suggestions.
__________________
and God said, Let the earth bring forth grass, Gen.1:11
All praise, all power, glory & majesty to The Holy One of Israel, the One which is, which was & which is to come
Reply With Quote
  #2  
Old 09-08-2007, 03:08 PM
topsites topsites is offline
LawnSite Fanatic
 
Join Date: Mar 2005
Location: Richmond Virginia
Posts: 21,677
No, some to all (stihl) 2-cyclers do that crap, not sure about other brands but with stihl it's normal and no fun.
Most don't do it when they're new, and I can't remember if Echo does it because I run almost all Stihl's and just about every one of them did this to me at some point in time, not sure on the 4-mix'rs because they came out later but the 2-cyclers ALL do it (chainsaws, trimmers, edgers, blowers, you name it).

It's a royal pita, I know all about it, shut it down when hot and you got two choices: Either start it RIGHT back up or let it cool for 15-20 minutes, it will NOT start any other way, not that I know of.

Over time I simply trained myself to finish whatever work so long the tool was running, never shut a tool off until I'm done with it, so then this method eventually became second nature so I haven't had this problem in years, but yeah it was a fun learning experience.
Reply With Quote
  #3  
Old 09-08-2007, 03:26 PM
lawnboy dan lawnboy dan is offline
LawnSite Gold Member
 
Join Date: Oct 2005
Location: north florida
Posts: 3,437
ing module. these model sthil are famous for this. i dont use this model any longer due to this problem. there should be a life time warrenty on this defective part or a recall but there isnt
Reply With Quote
  #4  
Old 09-08-2007, 06:41 PM
DSIM's Avatar
DSIM DSIM is offline
LawnSite Senior Member
 
Join Date: Jul 2004
Location: Arlington, Texas
Posts: 437
ok, we know the symptoms but what is the source of the problem?

I found a website that sells the ignition module for $24.95. Cheap enough IF that will fix it.
__________________
and God said, Let the earth bring forth grass, Gen.1:11
All praise, all power, glory & majesty to The Holy One of Israel, the One which is, which was & which is to come
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 11:12 PM.

Page generated in 0.07048 seconds with 9 queries