Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 11-19-2001, 11:35 PM
PetalsandPines PetalsandPines is offline
LawnSite Member
 
Join Date: Mar 2001
Location: Buffalo NY
Posts: 248
1997 Ford f350 Low Range 4x4 Slipping?

I have the 1997 F350 (old body style), Doing a dry run the other day to make sure everything is ready for winter I engaged the truck in LOW RANGE 4x4, I rarely use the Low Range, if ever. Well after engaging it and putting it in drive, I pressed the gas and the engine reved, the truck went slowly as if it was slipping then BAM, the wheels engaged. I did it again and the engine reved and reved and then eventually it kicked in. Is this normal for LOW RANGE 4x4 (auto tranny), because the 4X 4 high is working perfectly (no reving or slipping) the fluids are fine, not burn't. I have never run 4 low unless it was in snow...so I don't know if this is normal...Any help out there?
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 05:45 AM.

Page generated in 0.08823 seconds with 8 queries