Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
Reply
 
Thread Tools Display Modes
  #1  
Old 04-06-2007, 06:45 PM
scottt scottt is offline
LawnSite Senior Member
 
Join Date: May 2000
Location: Oklahoma
Posts: 269
Chainsaw won't run

I have a stihl chainsaw that won't keep running. If I put a shot of carb cleaner in it it will run for a second and then dies. The filter was caked with wood shavings. Do I need to clean out the carb? If so, how do I get the air fuel mixture back to where it was?
Reply With Quote
  #2  
Old 04-06-2007, 07:00 PM
scottt scottt is offline
LawnSite Senior Member
 
Join Date: May 2000
Location: Oklahoma
Posts: 269
By the way, it's a ms290.
Reply With Quote
  #3  
Old 04-07-2007, 09:57 AM
wpark wpark is offline
LawnSite Member
 
Join Date: Mar 2007
Location: SC
Posts: 3
I'm working on an older Stihl chain saw with the same problem. I had to repair the recoil assembly first so I haven't got into the failure to start just yet but here are things I will check:
It's not getting any fuel. To determine this, check the spark plug to see ir it is wet. My case, the plug is dry.
Check for fire. Replace plug. It's a good and inexpensive idea to go ahead and replace the plug. Sometimes, the plug may spark, but it still won't start the engine.
Check the fuel filter inside the fuel tank.
Check and replace the fuel lines. If there is even a pin hole in the fuel line the saw may start, but will cut off because it will pull a vacuum through this pin hole.
Clean the car. with carb cleaner before removing.
Finally, if all the above fail, remove the carb., check the diaphragm, float, and needle valve assembly.
Well, that's about all there is to it. Check for the easy fixes first and work you're way up. One more important thing I left out- FUEL. make sure there's plenty in the tank of the correct mixture and it's not stale.
Hope this helps.
Reply With Quote
  #4  
Old 04-07-2007, 11:16 AM
scottr 2006 scottr 2006 is offline
LawnSite Member
 
Join Date: Apr 2006
Location: alabama
Posts: 70
Quote:
Originally Posted by scottt View Post
I have a stihl chainsaw that won't keep running. If I put a shot of carb cleaner in it it will run for a second and then dies. The filter was caked with wood shavings. Do I need to clean out the carb? If so, how do I get the air fuel mixture back to where it was?
If you try to hold the saw up by the starter rope does it drop or unwind slowly ?
Reply With Quote
  #5  
Old 04-07-2007, 11:44 AM
Albery's Lawn & Tractor's Avatar
Albery's Lawn & Tractor Albery's Lawn & Tractor is offline
LawnSite Bronze Member
 
Join Date: Jan 2007
Location: Denver, CO
Posts: 1,675
Pull the carb off, clean it, and make sure none of the ports are clogged. As far as the air & fuel mixture goes, I know my echo's are 1.5 turns out is factory, but just sit it on the bench and you can adjust it till it feels right.
Reply With Quote
  #6  
Old 04-07-2007, 11:26 PM
SLR's Avatar
SLR SLR is offline
LawnSite Gold Member
 
Join Date: Jan 2006
Location: Zone of young lions
Posts: 3,233
Quote:
Originally Posted by scottr 2006 View Post
If you try to hold the saw up by the starter rope does it drop or unwind slowly ?

For the life of me i cannot wrap my head around this one..what are you saying?
Reply With Quote
  #7  
Old 04-08-2007, 08:59 AM
scottr 2006 scottr 2006 is offline
LawnSite Member
 
Join Date: Apr 2006
Location: alabama
Posts: 70
Quote:
Originally Posted by SLR View Post
For the life of me i cannot wrap my head around this one..what are you saying?
It is an easy and quick way to test the compression . It might fire on starting fluid but not have enough compression to run .
Reply With Quote
  #8  
Old 04-08-2007, 10:31 AM
mini14's Avatar
mini14 mini14 is offline
LawnSite Member
 
Join Date: Jun 2005
Location: long island
Posts: 236
check for cracked/broken fuel lines sounds like your saw isnt geten fuel.
Reply With Quote
  #9  
Old 10-07-2007, 11:16 AM
KRH KRH is offline
LawnSite Member
 
Join Date: Oct 2007
Location: Bainbridge, Indiana
Posts: 1
HELP!!!! I have a 028wb chainsaw.Don't seemto be getting good spark,plug looks fine.Does anyone know what the mag.is to to be set at.Ran fine died now won't start.Clean filter in the tank,won't fire when trying to start it.The reply about the gas line with a hole might be it,haven't checked that yet.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 07:33 AM.

Page generated in 0.09147 seconds with 9 queries