Register free!

The Green Industry's Resource Center


 
 
Thread Tools   Display Modes
  #1  
Old 10-06-2007, 12:17 AM
syzer syzer is offline
LawnSite Bronze Member
 
Join Date: Aug 2000
Location: Maryland
Posts: 1,265
Big problem with our beloved Hustler Super Walk Behind

The other day I have my guy come up to me and walk me over the the SWB and ask me why it looks like a low rider. I was wondering what was going on and upon closer inspection I noticed a problem I had spotted way early on was getting much worse. I am becoming worried about this high dollar machine.

A while back I noticed what seemed to be like the mower squatting, like the wheels were being bent in the air. I thought I was crazy, but now, WOW is it more obvious then ever.


This is what kills me, I loved this machine so much that I bought another one, it was supposed to be the last new SWB in any dealer last year. So I look under the bent mower chassis, and right where the wheels stick out from the frame there are two gussets (on the inside), then a small bar attaching them together. So I look under the new one we built last year, and what did I see? Oh, a revision, instead of only the two gussets being attached to each other via a bar, the bar runs across the whole bottom which supports the whole side.

This has me absolutely furious, ad I sure hope I can get something taken care of here with Hustler.

PJ any ideas of where I can turn?

Here are some pics:




__________________
Chris
  #2  
Old 10-08-2007, 06:14 PM
mowerconsultant's Avatar
mowerconsultant mowerconsultant is offline
LawnSite Fanatic
 
Join Date: Feb 2000
Location: Syracuse, NY
Posts: 9,753
There is information that I need here, model and serial #'s of both units and dates of purchase.
Then I can look into it a bit, or better yet, have you talked to your dealer about this?
__________________
  #3  
Old 10-09-2007, 06:31 PM
syzer syzer is offline
LawnSite Bronze Member
 
Join Date: Aug 2000
Location: Maryland
Posts: 1,265
Quote:
Originally Posted by mowerconsultant View Post
There is information that I need here, model and serial #'s of both units and dates of purchase.
Then I can look into it a bit, or better yet, have you talked to your dealer about this?
I will get you the information you asked. I have talked to Jim at Lyons and Lyons, he doesn't know what to say other then drop you guys a line, and hope you have an old SWB frame laying around =(.

Both Units purchased last year, one used (the bent frame, only 60 hours on it, and straight when we received it) and the other brand new.
__________________
Chris
  #4  
Old 10-12-2007, 06:01 PM
syzer syzer is offline
LawnSite Bronze Member
 
Join Date: Aug 2000
Location: Maryland
Posts: 1,265
#1 Bent Frame:
Frame s/n: 5092379
Engine s/n: FH721VB52761
Model: SWB 927137
Year: 04/05?

#2 Good Frame:
Frame s/n: 3060004
Engine s/n:FH721VB16506
Model#: SWB 927137
Year: 06
__________________
Chris
  #5  
Old 10-12-2007, 06:56 PM
JW Lawn JW Lawn is offline
LawnSite Member
 
Join Date: Oct 2006
Location: Rising Sun MD
Posts: 48
I am dealing with Hustler right now with a unit that has been out of warranty for (3)months...All I can say is that they have been awesome at doing everything possible to get me back on my mower quickly!!!!
__________________
Hustler Super Z 60"
Quick 36 Samurai
Sthil br600
2 Echo 260T
Shindaiwa 260 Edger
2 Echo CS-440
Husqvarna 326HD
www.BTLS.com
  #6  
Old 10-12-2007, 07:24 PM
mowerconsultant's Avatar
mowerconsultant mowerconsultant is offline
LawnSite Fanatic
 
Join Date: Feb 2000
Location: Syracuse, NY
Posts: 9,753
Quote:
Originally Posted by syzer View Post
#1 Bent Frame:
Frame s/n: 5092379
Engine s/n: FH721VB52761
Model: SWB 927137
Year: 04/05?

#2 Good Frame:
Frame s/n: 3060004
Engine s/n:FH721VB16506
Model#: SWB 927137
Year: 06
You are missing 0's in the beginning of both serial # I believe.

According to what you have posted here #2 is the older unit, built in 2003.
#1 was built in 2005

Did your dealer call the factory and get working on this for you?
If not e-mail me and I will get our regional manager looking into the situation for you.
__________________
  #7  
Old 10-12-2007, 07:59 PM
syzer syzer is offline
LawnSite Bronze Member
 
Join Date: Aug 2000
Location: Maryland
Posts: 1,265
Quote:
Originally Posted by mowerconsultant View Post
You are missing 0's in the beginning of both serial # I believe.

According to what you have posted here #2 is the older unit, built in 2003.
#1 was built in 2005

Did your dealer call the factory and get working on this for you?
If not e-mail me and I will get our regional manager looking into the situation for you.

I will double check, I pulled these from or equipment list, so there is a possibility the #'s may have 0's in front. Its the older unit that has the bends, so I will verify the serial number and the machine tomorrow morning.

The dealer told me to contact you guys and see if there is something you would do about the issue, so no he isnt doing anything for us. I will email you, thanks.
__________________
Chris
  #8  
Old 10-15-2007, 05:45 PM
mowerconsultant's Avatar
mowerconsultant mowerconsultant is offline
LawnSite Fanatic
 
Join Date: Feb 2000
Location: Syracuse, NY
Posts: 9,753
Quote:
Originally Posted by syzer View Post
I will double check, I pulled these from or equipment list, so there is a possibility the #'s may have 0's in front. Its the older unit that has the bends, so I will verify the serial number and the machine tomorrow morning.

The dealer told me to contact you guys and see if there is something you would do about the issue, so no he isnt doing anything for us. I will email you, thanks.
E-mail me and I will have someone look into the situation for you.
__________________
  #9  
Old 10-17-2007, 02:51 PM
syzer syzer is offline
LawnSite Bronze Member
 
Join Date: Aug 2000
Location: Maryland
Posts: 1,265
Just shot you an email. Thanks.
__________________
Chris
  #10  
Old 10-18-2007, 06:05 PM
mowerconsultant's Avatar
mowerconsultant mowerconsultant is offline
LawnSite Fanatic
 
Join Date: Feb 2000
Location: Syracuse, NY
Posts: 9,753
Quote:
Originally Posted by syzer View Post
Just shot you an email. Thanks.
I received it and forwarded to our regional manager.
__________________
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Layout Style:





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 05:24 PM.

Page generated in 0.09665 seconds with 9 queries