Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
Reply
 
Thread Tools Display Modes
  #1  
Old 01-21-2002, 09:42 AM
suburbanrob suburbanrob is offline
LawnSite Member
 
Join Date: Dec 2000
Location: Houston, TX
Posts: 21
99 GMC Suburban start up rattle

We're looking at a 99 GMC Suburban, 5.7 vortec. After sitting for 10-15 minutes when it's hot we hear a nice rattle in the engine until the oil pressure comes up. Dealer says this is normal on this one. Funny thing is a couple friends have the same model and theirs seem to do the same thing. Runs fine and makes no noise after that. I talked to the previous owner and he said he the truck has never been in the shop for anthing. The truck has 35k on it so I'm close the end of the warranty.

Anobody seen this?

Thanks,
Rob
__________________
.
Reply With Quote
  #2  
Old 01-21-2002, 10:40 AM
Randy Scott Randy Scott is offline
LawnSite Bronze Member
 
Join Date: Nov 2000
Location: Wisconsin
Posts: 1,915
I had a '98 GMC with the 5.7 and my buddy also still has the same truck. Another buddy has a '96 with the 5.7. 2 of the 3 of our trucks have a motor knock only when it's cold out, mostly winter. Usually when the temp starts to get towards freezing and lower. It does it until the motor warms up a bit. The father of one of my buddies works at an engine shop and he said most likely it is just a tolerance in the piston skirt, or wrist pin, or something like that. It warms up and expands a little and it is fine. My truck had 60,000 on it when I got rid of it and was still running fine. My other buddies still have theirs with about the same mileage on them and they seem to be o.k. The salesman we all bought our truck from is our friend and he said there is alot of complaints about that noise but really haven't had any premature failures. Personally, it drove me nuts with mine. That's BS to buy a new truck and have it make a knock like that after 20,000 miles. Not too happy with GM on that one but whatever, maybe that's why I don't have another one.
Reply With Quote
  #3  
Old 01-21-2002, 12:35 PM
suburbanrob suburbanrob is offline
LawnSite Member
 
Join Date: Dec 2000
Location: Houston, TX
Posts: 21
Thanks for the reply. If I understand correctly mine is sort of opposite. If it sits overnight, no knocking. Only if it's hot and has sat for 5-10 minutes. It's as if the oil has drained from the galleys and is running dry. Funny thing is the oil would have drained from a overnight as well (where there is no knock). But at least when the engine is cold parts have not expanded as they do when hot.

Rob
__________________
.
Reply With Quote
  #4  
Old 01-21-2002, 01:05 PM
Randy Scott Randy Scott is offline
LawnSite Bronze Member
 
Join Date: Nov 2000
Location: Wisconsin
Posts: 1,915
Yeah, that's strange. Then perhaps it has a lifter that may take a little longer to pump up than the others. But you think it would do it cold also. I don't know, you got me! Good luck with it though.
Reply With Quote
  #5  
Old 01-21-2002, 06:40 PM
jc1 jc1 is offline
LawnSite Senior Member
 
Join Date: Nov 2001
Location: The Real South Jersey
Posts: 562
There is the possibility that the oil filter my not have a check valve in it or a defective one. Therefore is is allowing the oil to drain back when the engine is hot. That is often a problem with cheap filters. A few years back gm changed alot of there filters so they have check valves in them now.
Reply With Quote
  #6  
Old 01-21-2002, 08:28 PM
suburbanrob suburbanrob is offline
LawnSite Member
 
Join Date: Dec 2000
Location: Houston, TX
Posts: 21
Another good suggestion, but I tried it already (I used to be in the repair business). I figure a $4 filter was worth a try. The dealership had already done a oil change. I just spun that one off and replace it. No change.

Thanks,
Rob
__________________
.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 01:00 PM.

Page generated in 0.09001 seconds with 9 queries