Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
Reply
 
Thread Tools Display Modes
  #1  
Old 07-16-2008, 11:57 AM
lawnoasis lawnoasis is offline
LawnSite Member
 
Join Date: Jan 2000
Location: Omaha
Posts: 16
Exmark Engine Run On

I have an eight yr old exmark 60"ZTR with 2500+ hrs on it, I let it idle for 2 mins or so before I shut it off, but it continues to run on after that. Could this be anything other than carbon deposits on the piston heads? What's the best product out there for cleaning fuel deposits? Thanks.
__________________
"It takes a lot of money to break even!"
Reply With Quote
  #2  
Old 07-16-2008, 01:53 PM
fixer67's Avatar
fixer67 fixer67 is offline
LawnSite Silver Member
 
Join Date: Apr 2004
Location: Tryon NC
Posts: 2,161
Quote:
Originally Posted by lawnoasis View Post
I have an eight yr old exmark 60"ZTR with 2500+ hrs on it, I let it idle for 2 mins or so before I shut it off, but it continues to run on after that. Could this be anything other than carbon deposits on the piston heads? What's the best product out there for cleaning fuel deposits? Thanks.

What do you mean by "run on"? Do you have to pull the plug wire to shut it down or does it have a delay before it shuts down and how does it sound when it does shut down. Need a little more to go on.
__________________
"DEFECTIVE OWNER/OPERATOR NOT COVERED UNDER WARRANTY"
Reply With Quote
  #3  
Old 07-16-2008, 02:03 PM
lawnoasis lawnoasis is offline
LawnSite Member
 
Join Date: Jan 2000
Location: Omaha
Posts: 16
It can run for 2-5 secs after I shut it off, (rough diesling) It will eventually stop on its own. Thanks.
__________________
"It takes a lot of money to break even!"
Reply With Quote
  #4  
Old 07-16-2008, 02:10 PM
fixer67's Avatar
fixer67 fixer67 is offline
LawnSite Silver Member
 
Join Date: Apr 2004
Location: Tryon NC
Posts: 2,161
Is the fuel solenoid working? Is the kill switch working? I have seen engine where the kill switch stopped working and when the switch shut off power to the fuel solenoid it took the engine a few seconds to run the last bit of fuel out of the carb pick up tube. Try this. Hook a inline spark tester on the spark plug. Start the engine. Watch the tester. Does the tester stop as soon as you the switch or does it keep firing until the engine stops?
__________________
"DEFECTIVE OWNER/OPERATOR NOT COVERED UNDER WARRANTY"
Reply With Quote
  #5  
Old 07-16-2008, 06:00 PM
chesterlawn's Avatar
chesterlawn chesterlawn is offline
LawnSite Senior Member
 
Join Date: Oct 2005
Location: s.e. pa.
Posts: 646
After you are done cutting, don"t just let it idle keep it at 1/2 throttle for about 30 seconds then turn the key off.
Reply With Quote
  #6  
Old 07-16-2008, 07:20 PM
lawnoasis lawnoasis is offline
LawnSite Member
 
Join Date: Jan 2000
Location: Omaha
Posts: 16
Thanks chester, I'll try that. I did replace the original ignition switch today to no avail. Starts great, runs great. Don't know why it's doing this lately. It does it about 80% of the time usually after long hot runs.
__________________
"It takes a lot of money to break even!"
Reply With Quote
  #7  
Old 07-16-2008, 07:24 PM
fixer67's Avatar
fixer67 fixer67 is offline
LawnSite Silver Member
 
Join Date: Apr 2004
Location: Tryon NC
Posts: 2,161
Hook a inline spark tester up to the spark plug. See if it still has spark after the switch is turned off. IF it does then it is a grounding problem in the kill circuit. I have seen coils go bad by losing the ground part of the kill circuit when they get hot.
__________________
"DEFECTIVE OWNER/OPERATOR NOT COVERED UNDER WARRANTY"
Reply With Quote
  #8  
Old 07-16-2008, 11:27 PM
2stroke 2stroke is offline
LawnSite Member
 
Join Date: Apr 2006
Location: Grand Junction Co. zone 3
Posts: 237
turn the idle down.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 07:29 PM.

Page generated in 0.09108 seconds with 9 queries