Register free!

The Green Industry's Resource Center



Reply
 
Thread Tools   Display Modes
  #1  
Old 01-16-2003, 11:47 PM
General Grounds General Grounds is offline
LawnSite Senior Member
 
Join Date: Jan 2001
Location: Manalapan,nj
Posts: 902
problem with 8hp briggs on sander

lately ive been having a problem starting my sander, i choke it and it will not turn over, i spray a little starter fluid and it fires up and will run fine, im thinkin the choke isnt closing all the way though it appears to be doing so when the cable is applied. i did a conpression test and it is around 90 psi, im thinkin this is off a little not sure of the ratio so i cant figure out what the psi should be, im quessing should be like 120 psi. thanks tony
Reply With Quote
  #2  
Old 01-17-2003, 12:10 AM
Jason Pallas Jason Pallas is offline
LawnSite Bronze Member
 
Join Date: Jan 2001
Location: Grosse Pointe. MI
Posts: 1,321
defintely check to make sure that choke is closing all the way and seating well for a good close-off of air - if that's not it, try opening up the fuel mix adjustment on the carb about 1/4 to 1/2 a turn counterclockwise. If neither of those help, it's time to look at taking the carb apart for a cleaning, if no, take the head off the engine and see that the valves are seating well. If all those things don't seem to help, THEN look at tearing down the engine to put new rings in. I don't know the compression specs for the Briggs 8hp - call the nearest dealer, that's something their repair staff should know off the top of their head. Good luck.
Reply With Quote
  #3  
Old 01-17-2003, 12:33 AM
khouse khouse is offline
LawnSite Bronze Member
 
Join Date: Feb 2001
Location: lee's summit, mo
Posts: 1,479
Do what Jason says about the choke. If closing all the way then rebuild the carb. If it's not closing fix that. I believe the 8 hp has a crappy throttle/choke linkage and usually needs some tinkering. 90 lbs is OK so don't worry about a engine rebuild. Also in you saying after it starts it runs fine tells me it's just in the carb.
Reply With Quote
  #4  
Old 01-26-2003, 10:59 PM
Mr.Wrench Mr.Wrench is offline
LawnSite Member
 
Join Date: Jan 2003
Location: N.H.
Posts: 65
One of our major landscapers had this very same problem the last big storm. The remote cable does not give enough push to engage the choke. These engines take a trashing hanging back there in the dust and salt. Keep everything lubed and much as possible, and adjust your cable accordingly. We see most spreader engines only lasting about 2 years. They fail mostly because of sever salt damage and lack of preventative maintenance.
Reply With Quote
  #5  
Old 01-26-2003, 11:01 PM
Mr.Wrench Mr.Wrench is offline
LawnSite Member
 
Join Date: Jan 2003
Location: N.H.
Posts: 65
Oh, sorry I forgot. Your compression is dead on. A typical B&S 8hp vertical cranks at around 90psi until the compression release kicks off.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 01:53 PM.

Page generated in 0.07038 seconds with 9 queries