Register free!

The Green Industry's Resource Center


 
 
Thread Tools   Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 05-19-2010, 12:56 PM
rob7233's Avatar
rob7233 rob7233 is offline
LawnSite Senior Member
 
Join Date: Feb 2005
Location: 9b Central FL
Posts: 783
It's a Mystery - Recoil rips out your hand !!

I have a 1996? Kawasaki FC420v -S09, 14HP engine w/ the ACR that has a history of hurting people and cutting their hands open from the pull cord suddenly ripping out your hands when pulling the recoil. This walkbehind has been a back up for years but recently, I needed to loan it out to a friend. Even with explicit warning and instruction to pull the cord slowly all the way out before trying to start it, he still got cut up.

Last time I used it, it was running rich and the the plug was sooty black. Since then it has a new plug and a professional carb adjustment and pretty much starts on the first pull with a healthy tug. I now have the machine being looked by a quality shop where the folks there seem to know what they're doing and are familiar with this engine. This is what they checked so far:

1) The mechanical ACR release works and lifts the valve as it supposed to.
2) They have checked the valves and fine tuned the adjustment while they were there(nothing unusual noted).
3) The engine still seems a little harder to pull than normal (Could it be too much compression??) Now this has been typical for it..
4)They are doing a compression check on it now
5) The shop has even called Kawasaki and asked if there was something else they could do or look for -- Kawasaki's reply was to "just pull harder" WTF?!!

Could this be from a buildup in carbon? I've run seafoam thru it in the past and didn't see any change in recoil resistance. I know I've had "running on" issues with it in the past especially when it got hot from use. However, it hasn't done that since the Seafoam. Should I try the LMT -Lawn mower tuneup by Blaster? It does do a good job at removing carbon.

Now I'm just guessing what might be the problem. It's still a mystery.
Does anybody have any suggestions or clues to the problem?
Reply With Quote
 

Tags
14hp , engine , fc420v , kawasaki , recoil

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 01:06 AM.

Page generated in 0.15700 seconds with 8 queries