Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 11-16-2010, 08:57 PM
Blazerfb Blazerfb is offline
LawnSite Member
 
Join Date: Dec 2008
Location: Birmingham, AL
Posts: 136
Grandstand not moving at full speed....hydro oil?

My 23hp 2009 Toro Grandstand is running at about 5-6 mph instead of 7-8. I'm wondering if maybe i need a new hyrdaulic oil filter and possibly need to change the oil as well.

No idea how long it has been since servicing. Mower has 530 hrs, bought it used not long ago from an old friend. His crew does a half ass job of maintaining mowers. Hydro oil is slightly low but i don't think that's it. I reset the linkage and tracking, got a little more speed.

Any ideas???? Suggestions??? Just trying to get it running at full ground speed so i can continue to make money with it! (everything else is running great: motor, blade speed, etc.)
__________________
Edge to Edge Lawn and Landscape
Birmingham, AL

Stihl and Exmark dude.

Stand-On mowers are underrated!

*Being a landscaper does not require being a businessman, but it sure does make it easy*


Reply With Quote
 

Tags
grandstand , hydro , hydro oil , mower speed

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 04:26 AM.

Page generated in 0.08073 seconds with 8 queries