Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 03-28-2003, 07:11 AM
djsmokin djsmokin is offline
LawnSite Member
 
Join Date: Feb 2003
Location: Fort Walton Beach, FL
Posts: 127
New Echo PB650 running bad

I have an Echo PB650 with about 10 hours of time on it. Last couple of days it takes spells of running bad. Runs great sometimes then runs like it only has half power. Sometimes it surges and then it might run great. Does this when warm or cool, never know when it will do it.

Airfilter is clean, muffler looks clean on the screen, plug looks great, I have taken off the gas cap on the tank and it still does the samething...so fuel vent is not problem.

I am running 87 octane name brand fuel.

Have not taken it to the dealer yet because it might just run great when I do. Any ideas for me?

Also, is there a high speed fuel air mixture screw on that carb? I can't find one. Thanks. Dj
__________________
If you travel at the speed of light, would your headlights work?
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 07:25 AM.

Page generated in 0.10598 seconds with 8 queries