Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 04-22-2011, 08:55 PM
Baytownlawncare Baytownlawncare is offline
LawnSite Member
 
Join Date: May 2010
Location: Baytown, TX
Posts: 236
Kombi system shaft failure (edger)

I have a Stihl KM 110 R that I use a curved shaft edger with. I love the edger and it does a really good job but the shafts in the edger keep fraying at the end where it engages the motor. The super dealer I have has replaced twice free. I have disconnected a few times to put on the hedge trimmer attachment. I am inserting it all the way to the line and the dealer checked the alignment with the motor and found no issues. It frays right at the end and then will not go into the motor at all. Anything you guys think I am doing to cause this? The last shaft they installed looked to be a better design and they double checked to make sure it was the right part number. Anyway is anybody else having these issues?
__________________
Full time Certified Pharmacy Technician
Part time Lawn Care Professional
2004 Nissan Titan
36" Scag V-Ride
33" 760 ES Cub Cadet(backup)
22" Toro Self Propelled
21" Push Yard Machine
Stihl Kombi 110 with curved edger
Stihl Kombi 90 with straight shaft trimmer
Echo String Trimmer (backup)
Echo HH Blower
McLean Edger(backup)

http://baytownlawncare.com
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 09:14 PM.

Page generated in 0.08312 seconds with 8 queries