Register free!

The Green Industry's Resource Center


 
 
Thread Tools   Display Modes
  #1  
Old 06-24-2011, 08:48 PM
marcs hustler marcs hustler is offline
LawnSite Member
 
Join Date: Jun 2011
Location: HERSHEY,PA
Posts: 8
Sport mulch kit help

i just bought my sport 2weeks ago and i just installed my mulch kit for my sport. the kit included 2 blades, shoot blocker, and a piece the goes between the two blades. i just used it today and i noticed it leaving rows of uncut grass. why is this?
i dont want to used the side discharge. can i just put the regual blades back on and keep the rest of the kit installed?
  #2  
Old 06-29-2011, 03:02 PM
mowerconsultant's Avatar
mowerconsultant mowerconsultant is offline
LawnSite Fanatic
 
Join Date: Feb 2000
Location: Syracuse, NY
Posts: 9,753
The regular blades will make it worse.
For mulching to work you need to use the mulching blades and the baffle and close off plate.
You also need to vary your ground speed and how much your taking off in a single pass.
The grass needs to be as dry as possible also.
Double check your blade belt tension also.
The deck needs time to process the grass accordingly.
Are the blades on correct also?
Using the stock blades with the close off plate will just clump grass up under the deck and leave piles in the lawn.
If you do all of the above you will have excellent mulching results.

Pj
__________________
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Layout Style:





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 10:11 PM.

Page generated in 0.05810 seconds with 9 queries