Register free!

The Green Industry's Resource Center



Reply
 
Thread Tools   Display Modes
  #11  
Old 03-22-2012, 11:51 PM
tonygreek's Avatar
tonygreek tonygreek is offline
LawnSite Silver Member
 
Join Date: Aug 2004
Location: Lancaster, PA
Posts: 2,797
Quote:
Originally Posted by TwigsLawnCare View Post
Thank you once again. I will have to do some more reading on the sitemap and robots thing. I'm still learning this stuff.

What are you doing to look for it. I have IE9. Should I see it in view source?
I'm seeing those sitemaps, but not seeing this one:
http://www.twigslawncare.com/sitemap_index.xml

Any browser will open an xml file.

It's great you're learning and processing this instead of just looking for it to be handed to you or simply applying what's suggested without trying to understand it. No doubt you'll reap more of the benefits of this over time.
Reply With Quote
  #12  
Old 03-23-2012, 03:16 AM
greg8872 greg8872 is offline
LawnSite Senior Member
 
Join Date: Jan 2012
Location: Upper Arlington, Ohio
Posts: 275
Been busy, and finally had a day to get caught up on things now that I'm home after being gone for nearly 2 months.... I skimmed through the thread so far, so please forgive me if I hit something already discussed:

Main thing I notice, when I go to your site. my first thought "Where are you?" Now, in general, may not be such an issue for your site, as most people coming to your site from search engine will have probably been using some kind of geographical data to narrow down the search results, and people entering it by hand, will have probably seen it on your equipment and/or heard it from someone in your area. That being said, I would add in (even is slightly smaller) the area code into you header.

In the footer, I would add a little formatting to the timestamp on the blogs to make it easier to read such as the following example:

about 112 days ago It's been a great Fall weather wise.

about 112 days ago It's been a great Fall weather wise.

Overall, I like the look of the site, so here is more the technical side and mistakes:

http://twigslawncare.com/services/landscaping/
Twigs Lawn Care excells in small to meduim size should be excels and medium
we’ll be happy to dicuss your project should be discuss

http://twigslawncare.com/services/
Property and Grounds Maintaince Services Include should be Maintenance

http://twigslawncare.com/contact/
to recieve a free estimate should be receive (also in the META Description, but that will probably update when you update content, but double check)

http://twigslawncare.com/services/lawn-mowing/
Premuim Cut and Trim should be Premium

On many pages, where you have the Twitter and LinkedIn section in the right column, you accidentally have &nbsp instead of a   (Do a view source, then search for "nbsp&nbsp" and you will find where it is missing if you do it in firefox, you will see that it highlighted as broken (bold))

http://twigslawncare.com/2011/10/23/...-time-is-here/
The comment from "Troma", the name actually links to a non working link (starts with http:// yet is an email address) but this will come up as the page has a broken link

I like how you use some type of plugin so that your e-mail link uses a * insted of a @, then Javacript converts it, however at least on your home page, you still list out the e-mail address, so a scraper would still grab it. BTW, what plugin is that?

Your CSS (http://twigslawncare.com/wp-content/...cache/skin.css) calls two images that do not exist:
http://twigslawncare.com/wp-content/...put_bg.png.png
http://twigslawncare.com/wp-content/...n%20Mowing.png

Since it is Wordpress, I won't go much into the overly bloated code and excessive calls back to the server, but take a look at this report: http://gtmetrix.com/reports/twigslawncare.com/wNfVQjRv Go to the TIMELINE tab and you will see the large number of calls. Google now considers page load a factor in ranking. You rhome page is over 5 seconds to fully load. I see that it has history information on your site in HISTORY tab. You will also notice there that is reporting that it is 2 megs of data that gets downloaded (of course this could be including all the large images on slideshow on the home page, I prefer slideshows that only load first image, and the only after the page is loaded starts loading in the rest of them and displaying them.)

Again, as this is a WP theme, all the pages I tried will not validate. (http://validator.w3.org/)

Overall, nice looking site, I like it.

-Greg
Reply With Quote
  #13  
Old 03-24-2012, 10:10 AM
TwigsLawnCare's Avatar
TwigsLawnCare TwigsLawnCare is offline
LawnSite Member
 
Join Date: Nov 2011
Location: Rochester, NY
Posts: 16
Thank you greg8872.

I am an idiot when it comes to spelling - Thank you for pointing out the errors.

I believe the email link is from the theme. I use the striking theme.

I'll look into that CSS issue.

I'm still learning and working on speed. As you saw from the history tab, I have been looking into page speed. I just don't know enough yet.

Thanks
__________________
Twigs Lawn Care - www.twigslawncare.com
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 10:33 PM.

Page generated in 0.06177 seconds with 9 queries