Go Back   LawnSite.comô - Lawn Care & Landscaping Business Forum, Discuss News & Reviews > Sponsor Forums - Discuss with Sponsors Directly > Lawn Mowing Equipment & Accessories * * * * SPONSOR FORUMS > Hustler Turf Equip
User Name
Password
Home Products Find a Dealer News About Us Contact Us Mark Forums Read


Hustler Turf Equip Lawn Mowers & Turf Care Equipment

Reply
 
Thread Tools Display Modes
  #1  
Old 04-05-2012, 06:02 PM
mtmower's Avatar
mtmower mtmower is offline
LawnSite Bronze Member
 
Join Date: May 2008
Location: North Western Montana
Posts: 1,111
Hydo Reservior Gushing Fluid

PJ I'm concerned. My 66" XR7 Super Z just got its 1000 hr hydro service. I used the factory filter, added the correct amount of luberizol (sp?)(what is this wonderful snake oil anyway?) and filled the system with Amsoil. Bled the system parked it. Topped it up the following day. I installed the bagger (3) system and JRCO 60" thatch rake on it for the first time and used it on one yard and smelled some hot oil. Saw some oil had pushed by the reservoir cap and just thought I had over filled it and when it got hot it expanded and pushed out the excess. Next morning check fluids again and found the fluid level about an inch lower than the inch mark it should have been at. It was basically at the bottom of the screen insert. I topped it up again and it pushed it back out to the same point on the next couple yards. I'm guessing that I'm just pushing the hydro system harder than I had before but my early 60" standard deck with the same set up didn't have this problem.

On another note, what tire psi should one run when adding the bagger system. Couldn't find any recommendations in the manual. Deck cutting height is way off, which I can adjust for, and tires really flex like they might roll off the rim (front). I do have flex forks which is not helping the issue. I'm running 12 psi right now.

Thanks in advance.
Reply With Quote
  #2  
Old 04-09-2012, 12:32 PM
mowerconsultant's Avatar
mowerconsultant mowerconsultant is offline
LawnSite Fanatic
 
Join Date: Feb 2000
Location: Syracuse, NY
Posts: 9,751
Lubrizol is a Zinc additive to keep the oil "sticky" and sticking to the components in the hydro system so you don't have "dry" start ups with the system when you fire up the engine.
You do not use Lubrizol with synthetic oils, it sounds like you may have though, which would cause foaming of the oil and expansion in the reservoir.
You also may still have had some air in the system.
As to the tire pressure with the catcher, start at 10 psi and add a couple psi to you feel comfortable with it and it still has good traction.

Pj
__________________
Reply With Quote
  #3  
Old 04-09-2012, 04:33 PM
mtmower's Avatar
mtmower mtmower is offline
LawnSite Bronze Member
 
Join Date: May 2008
Location: North Western Montana
Posts: 1,111
I did two previous hydro changes at 45 hrs with syn. (mobile on) and lubrizol with no know problems. I'll top is up again and watch.

I ended airing the tires up up to 15 psi all the way around and it seems pretty happy.

Thanks
Reply With Quote
  #4  
Old 04-12-2012, 02:24 PM
Husqman Husqman is offline
LawnSite Member
 
Join Date: Jun 2001
Location: Tonkawa,Ok.
Posts: 42
The oil should be just touching the bottom of the screen sounds to me like you might be over filling the tank.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 07:32 PM.

Forum Rules:

This hustlerturfequipment.com sponsored forum is administrator monitored. LawnSite.com does not allow any manufacturer competitor attacks and will strongly enforce this. If you want your discussion to be viewable by the public and responded to in a professional manner then please keep your discussions professional and to the point.

All discussions are viewed by the administration before being released to the public. Your post may not be made viewable for up to 48 hours. Please allow the manufacturer representative enough time to respond to your question or comment once made viewable.

LawnSite.com is not affiliated with the Excel Hustler company. This forum is provided by LawnSite.com to Excel Hustler in order to better server their customers


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
Lawnsite,  Plowsite, WeldingWeb, LawnCareSuccess, Everythinggreen, & Lawnbusiness.net are trademarks of Lawn Care Success, Inc

Page generated in 0.07775 seconds with 9 queries