Go Back   LawnSite.comô - Lawn Care & Landscaping Business Forum, Discuss News & Reviews > Sponsor Forums - Discuss with Sponsors Directly > Lawn Mowing Equipment & Accessories * * * * SPONSOR FORUMS > Hustler Turf Equip
User Name
Password
Home Products Find a Dealer News About Us Contact Us Mark Forums Read


Hustler Turf Equip Lawn Mowers & Turf Care Equipment

Reply
 
Thread Tools Display Modes
  #1  
Old 05-01-2012, 07:09 PM
sbailey183 sbailey183 is offline
LawnSite Member
 
Join Date: Aug 2006
Location: Earlham, IA
Posts: 3
Super Z Mower Deck Won't Engage

I was mowing and stopped to pick up an item, disengaging the mower. I returned to the mower immediately and when I pulled the switch all I got was a click. I've had the unit for a few years and had this happen once before but I can't remember how I fixed the problem? Do I need a new switch or am I missing something else?
Reply With Quote
  #2  
Old 05-02-2012, 01:55 PM
mowerconsultant's Avatar
mowerconsultant mowerconsultant is offline
LawnSite Fanatic
 
Join Date: Feb 2000
Location: Syracuse, NY
Posts: 9,750
If your hearing a click I am guessing the clutch is engaging, I would check your belt for tension or to see if it broke or fell off? and if so why.

Pj
__________________
Reply With Quote
  #3  
Old 05-04-2012, 10:17 PM
sbailey183 sbailey183 is offline
LawnSite Member
 
Join Date: Aug 2006
Location: Earlham, IA
Posts: 3
It was the belt. Probably broke because I engaged the deck at high RPM's. My bad. I also found that the bold holding my tension arm was gone. Probably didn't help belt.

My model number is 926980 and I picked up a belt, part number 781310 but it's too long, even after using the tension adjustment. It shows on the part in the catalogue that it's 180". I measured the old one and that was 178" and I'm guessing that it could be stretched. The belt seems to be about 4" too long.

I'm the guy who didn't figure out on my own the belt was broke so I'm assuming I'm doing something wrong even though I've successfully installed belts on the unit before. Am I not adjusting the belt correctly or was I given the wrong one?
Reply With Quote
  #4  
Old 05-07-2012, 08:28 AM
mowerconsultant's Avatar
mowerconsultant mowerconsultant is offline
LawnSite Fanatic
 
Join Date: Feb 2000
Location: Syracuse, NY
Posts: 9,750
That is the correct part # belt for your deck.
I replied to your emails this am and sent you the manual with the belt diagram in it.

Pj
__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 11:08 PM.

Forum Rules:

This hustlerturfequipment.com sponsored forum is administrator monitored. LawnSite.com does not allow any manufacturer competitor attacks and will strongly enforce this. If you want your discussion to be viewable by the public and responded to in a professional manner then please keep your discussions professional and to the point.

All discussions are viewed by the administration before being released to the public. Your post may not be made viewable for up to 48 hours. Please allow the manufacturer representative enough time to respond to your question or comment once made viewable.

LawnSite.com is not affiliated with the Excel Hustler company. This forum is provided by LawnSite.com to Excel Hustler in order to better server their customers


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
Lawnsite,  Plowsite, WeldingWeb, LawnCareSuccess, Everythinggreen, & Lawnbusiness.net are trademarks of Lawn Care Success, Inc

Page generated in 0.06551 seconds with 9 queries