search sponsored by:
Advanced Search

The Green Industry's Resource Center

Prev Previous Post   Next Post Next
Old 05-29-2012, 09:34 PM
ncbowhnter ncbowhnter is offline
LawnSite Member
Join Date: Mar 2011
Location: sanford nc
Posts: 18
2011 Super Z died on me while cutting???

I have a 2011 Super Z Hyperdrive with roughly 150 hours on it. A few weeks ago while cutting the blades quit, then started back, then quit again. Then the mower died. I tried to start it back but it would just click when I turned the key. I noticed a little corrosion on the positive battery post so I cleaned it the best I could and then jumped it off. It did ok for about 2 minutes and then the exact same thing. I got it home, thoroughly cleaned the battery posts and put it on a battery tender and have not had a problem since.
I didn't really think anything of it until my buddy called me yesterday and his did the exact same thing. His has about 350 hours on it. Neither of our dealers have a clue why they did it...
anyone have any ideas? thanks for the help in advance.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Layout Style:

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 02:45 PM.

Page generated in 0.06018 seconds with 9 queries