Register free!

The Green Industry's Resource Center


Reply
 
Thread Tools   Display Modes
  #1  
Old 07-13-2012, 06:05 PM
aufire aufire is offline
LawnSite Member
 
Join Date: Feb 2004
Location: Auburn, Al.
Posts: 4
Walker Mower power issue

I have a 20 hp walker and when I engage the blades the engine seems to lug. The deck is 42in and the mower has 1300 hrs. Any ideas?
Reply With Quote
  #2  
Old 07-13-2012, 06:38 PM
nickslawnltd nickslawnltd is offline
LawnSite Member
 
Join Date: Aug 2011
Location: Grand Bend Ontario
Posts: 166
Like you don't have enough rpm?
Reply With Quote
  #3  
Old 07-13-2012, 07:20 PM
aufire aufire is offline
LawnSite Member
 
Join Date: Feb 2004
Location: Auburn, Al.
Posts: 4
When you activate the blades the mower lose power and then then regains power after 5-10 sec. It seems the rpms are lower. It's like the engine needs time to catch up. Thank you for any input.
Reply With Quote
  #4  
Old 07-13-2012, 08:57 PM
fixer67's Avatar
fixer67 fixer67 is offline
LawnSite Silver Member
 
Join Date: Apr 2004
Location: Tryon NC
Posts: 2,161
The specs for the Walker Kohler engine is NO LOAD 3750 RPM.
__________________
"DEFECTIVE OWNER/OPERATOR NOT COVERED UNDER WARRANTY"
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 10:13 AM.

Page generated in 0.06595 seconds with 9 queries